Bug 1016270 - Notification text should not be saved in preferred locale or language of the user
Notification text should not be saved in preferred locale or language of the ...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Localization and Internationalization (Show other bugs)
6.0.3
x86_64 Linux
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 15:01 EDT by Michaux Kelley
Modified: 2014-02-02 17:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 09:23:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multiple-languages-same-user (37.46 KB, image/png)
2013-10-07 15:01 EDT, Michaux Kelley
no flags Details

  None (edit)
Description Michaux Kelley 2013-10-07 15:01:24 EDT
Created attachment 808980 [details]
multiple-languages-same-user

Description of problem:
The list of notifications a user can see might consist of multiple languages
depending on which locale was selected at the time the notification was first
created. Notifications should be one language at a time. For example, if I
change my locale to "es" (Spanish), then the list of notifications available
to me should change to all Spanish rather than a mix of languages. 

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1.Click user drop-down in upper, right-hand corner
2.Select "My Account"
3.Select user in left-hand column on screen
4.Change "preferred locale"
5.Go to notifications at /katello/notices#/!=
6.The new notification should appear in the selected language
7.Change locale again. Steps 1-6 should be the same except for language.

Actual results:
Notices may appear in several different languages or locales at the same time.

Expected results:
Notices change with change of locale.

Additional info:
I didn't try this with different users. If the bug happens with multiple users,
the impact would be greater.
Comment 1 RHEL Product and Program Management 2013-10-07 15:06:07 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Bryan Kearney 2013-12-16 09:23:17 EST
Closing all i18n bus due to ne architecture. The goal is still a localized UI and CLI, but we will do this via a new round of testing.

Note You need to log in before you can comment on or make changes to this bug.