Bug 1016315 - Test failures in tasks-* quickstarts
Test failures in tasks-* quickstarts
Status: CLOSED DUPLICATE of bug 1015948
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: EAP 6.2.0
Assigned To: sgilda
Vladimir Rastseluev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 17:55 EDT by Paul Gier
Modified: 2017-10-09 20:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 19:54:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-10-07 17:55:05 EDT
Three quickstarts currently have test failures when running in arquillian managed and arquillian remote modes: tasks, tasks-jsf, tasks-rs.  For more details, see the jenkins jobs:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-handoff-quickstarts-arq-jbossas-managed/
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/job/eap-62-handoff-quickstarts-arq-jbossas-remote/

tasks
------
Failed tests:   taskDao_should_provide_basic_case_insensitive_full_text_search(org.jboss.as.quickstarts.tasks.TaskDaoTest): expected:<1> but was:<0>


tasks-jsf
---------
Failed tests:   facesContext_should_be_provided_from_current_context(org.jboss.as.quickstarts.tasksJsf.ResourcesTest)

Tests in error: 
  all_tasks_should_be_obtained_from_detachedUser(org.jboss.as.quickstarts.tasksJsf.TaskDaoTest): java.lang.IllegalStateException: EntityManager is closed
  range_of_tasks_should_be_provided_by_taskDao(org.jboss.as.quickstarts.tasksJsf.TaskDaoTest): java.lang.IllegalStateException: EntityManager is closed
  taskDao_should_remove_task_from_detachedUser(org.jboss.as.quickstarts.tasksJsf.TaskDaoTest): java.lang.IllegalStateException: EntityManager is closed
  taskDao_should_provide_basic_case_insensitive_full_text_search(org.jboss.as.quickstarts.tasksJsf.TaskDaoTest): java.lang.IllegalStateException: EntityManager is closed
  user_should_be_created_with_one_task_attached(org.jboss.as.quickstarts.tasksJsf.TaskDaoTest): EntityManager is closed
  user_should_be_retrievable_from_userDao_by_username(org.jboss.as.quickstarts.tasksJsf.UserDaoTest): java.lang.IllegalStateException: EntityManager is closed
  userDao_should_return_null_when_searching_for_non_existent_user(org.jboss.as.quickstarts.tasksJsf.UserDaoTest): java.lang.IllegalStateException: EntityManager is closed
  userDao_should_create_user_so_it_could_be_retrieved_from_userDao_by_username(org.jboss.as.quickstarts.tasksJsf.UserDaoTest): java.lang.IllegalStateException: EntityManager is closed

Tests run: 12, Failures: 1, Errors: 8, Skipped: 0


tasks-rf
--------
Failed tests:   taskDao_should_provide_basic_case_insensitive_full_text_search(org.jboss.as.quickstarts.tasksrs.TaskDaoTest): expected:<1> but was:<0>
Comment 1 Paul Gier 2013-10-07 19:54:01 EDT

*** This bug has been marked as a duplicate of bug 1015948 ***

Note You need to log in before you can comment on or make changes to this bug.