Bug 1016327 - Cairo Dock package preventing Fedora 18 upgrade to Fedora 20
Cairo Dock package preventing Fedora 18 upgrade to Fedora 20
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-upgrade (Show other bugs)
20
i686 All
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 19:25 EDT by Stephen Wilson
Modified: 2013-10-08 10:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 03:29:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Wilson 2013-10-07 19:25:08 EDT
Description of problem:
Fedora 18 with Cairo dock install cannot run yum --releasever=20 distro-sync. 

Version-Release number of selected component (if applicable):
Fedora 18

How reproducible:
Run yum --releasever=20 distro-sync on Fedora 18 with Cairo dock installed

Steps to Reproduce:
1. open terminal
2. run sudo yum --releasever=20 distro-sync
3.

Actual results:
Returns error message 

Error: Package: cairo-dock-plugins-3.2.1-1.fc18.i686 (@Cairo-Dock/18)
           Requires: libicalvcal.so.0
           Removing: libical-0.48-3.fc18.i686 (@anaconda/18)
               libicalvcal.so.0
           Updated By: libical-1.0-2.fc20.i686 (fedora)
               Not found
Error: Package: cairo-dock-plugins-3.2.1-1.fc18.i686 (@Cairo-Dock/18)
           Requires: libical.so.0
           Removing: libical-0.48-3.fc18.i686 (@anaconda/18)
               libical.so.0
           Updated By: libical-1.0-2.fc20.i686 (fedora)
               Not found
Error: Package: cairo-dock-plugins-3.2.1-1.fc18.i686 (@Cairo-Dock/18)
           Requires: libgnutls.so.26
           Removing: gnutls-2.12.23-2.fc18.i686 (@updates/18)
               libgnutls.so.26
           Updated By: gnutls-3.1.13-2.fc20.i686 (fedora)
               Not found
Error: Package: cairo-dock-plugins-3.2.1-1.fc18.i686 (@Cairo-Dock/18)
           Requires: libsasl2.so.2
           Removing: cyrus-sasl-lib-2.1.23-37.fc18.i686 (@updates/18)
               libsasl2.so.2
           Updated By: cyrus-sasl-lib-2.1.26-12.fc20.i686 (fedora)
               Not found
Error: Package: cairo-dock-plugins-3.2.1-1.fc18.i686 (@Cairo-Dock/18)
           Requires: libicalss.so.0
           Removing: libical-0.48-3.fc18.i686 (@anaconda/18)
               libicalss.so.0
           Updated By: libical-1.0-2.fc20.i686 (fedora)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Prompt asking y/n to download and install packages

Additional info:
Comment 1 Miroslav Suchý 2013-10-08 03:25:45 EDT
cairo-dock-plugins is not part of Fedora. From where you install that package?
Can I assume that it is from:
http://glx-dock.org/ww_page.php?p=Fedora%20repository&lang=en
?
Comment 2 Miroslav Suchý 2013-10-08 03:29:46 EDT
Especially that you install the package from their own repository (the first part of that page). Instead from rpmfusion (second part of that page).

Uninstall their repo:
 rpm -e dock
and do:
 rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm

Then the upgrade should work.
Comment 3 Stephen Wilson 2013-10-08 10:10:32 EDT
Understood. The install for Cairo dock should be from rpmfusion and not their repository. I already had the rpmfusion enabled as a repo but obviously the cairo-dock repo was taking precendence. Thank you.

Note You need to log in before you can comment on or make changes to this bug.