Bug 1016345 - Dependency Version Conflict Between libreoffice-core-4.1.2.3-1.fc20 and autocorr-en-4.1.2.3-2.fc19 when Attempting to Upgrade to Fedora 20
Dependency Version Conflict Between libreoffice-core-4.1.2.3-1.fc20 and autoc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
20
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 21:22 EDT by John Blakeney
Modified: 2013-10-12 00:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-4.1.2.3-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-12 00:31:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Blakeney 2013-10-07 21:22:57 EDT
Description of problem:
When trying to use yum's distro-sync feature to upgrade to Fedora 20 (pre-release), a version conflict involving LibreOffice components causes the operation to fail.

Version-Release number of selected component (if applicable):
4.1.2.3-2.fc19, upgrading to 4.1.2.3-1.fc20

How reproducible:
Always

Steps to Reproduce:
1. Install the latest LibreOffice on a Fedora 19 system, which should include the packages libreoffice-core-4.1.2.3-2.fc19 and autocorr-en-4.1.2.3-2.fc19 if using US English language support.
2. Run sudo yum --releasever=20 distro-sync

Actual results:
The following error is displayed, and the operation is aborted:
Error: Package: 1:libreoffice-core-4.1.2.3-1.fc20.i686 (fedora)
           Requires: autocorr-en
           Removing: 1:autocorr-en-4.1.2.3-2.fc19.noarch (@updates/19)
               autocorr-en = 1:4.1.2.3-2.fc19
           Available: 1:autocorr-en-4.1.2.3-1.fc20.noarch (fedora)
               autocorr-en = 1:4.1.2.3-1.fc20

Expected results:
No errors, and a prompt from yum asking whether to continue the upgrade

Additional info:
I found this issue by following the instructions on http://miroslav.suchy.cz/blog/archives/2013/10/07/donate_1_minute_of_your_time_to_test_upgrades_from_f19_to_f20/index.html , syndicated on Fedora Planet.  I wasn't actually planning to do a pre-release upgrade.
Comment 1 Caolan McNamara 2013-10-08 05:33:18 EDT
Just a temporary thing, one update got pushed before the other. e.g. https://admin.fedoraproject.org/updates/libreoffice-4.1.2.3-3.fc20 will sort this out when it get pushed
Comment 2 Fedora Update System 2013-10-08 05:33:57 EDT
libreoffice-4.1.2.3-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.1.2.3-3.fc20
Comment 3 Fedora Update System 2013-10-09 10:40:37 EDT
Package libreoffice-4.1.2.3-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.1.2.3-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18561/libreoffice-4.1.2.3-3.fc20
then log in and leave karma (feedback).
Comment 4 John Blakeney 2013-10-10 18:02:25 EDT
I ran sudo yum --enablerepo updates-testing --releasever=20 distro-sync, and the error did not appear this time, so it looks like this is fixed.  Thanks, Caolan!

I'll go ahead and close this bug.  As far as I can tell, CURRENTRELEASE is the most applicable status, but please let me know if I'm mistaken, or if I shouldn't have closed this myself.
Comment 5 David Tardon 2013-10-11 02:32:44 EDT
The right status for bugs that have been fixed by an update is CLOSED/ERRATA. But bodhi will do that automatically when the update is pushed to stable updates repository.
Comment 6 Fedora Update System 2013-10-12 00:31:22 EDT
libreoffice-4.1.2.3-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.