Bug 1016373 - Met clear /etc/puppet/puppet.conf issue
Met clear /etc/puppet/puppet.conf issue
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 00:31 EDT by haiyang,dong
Modified: 2014-01-21 14:52 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
Previously when clicking the "Save" button to save the puppet configuration, it would clear /etc/puppet/puppet.conf. This was due to a problem in the code. When "Save" is clicked now, the puppet configuration information is saved in /etc/puppet/puppet.conf.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:52:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-10-08 00:31:14 EDT
Description of problem:
Using edit-node install ovirt-node-plugin-puppet into rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso        ,
enter into puppet page and enabled puppet service and configure the puppet server
and puppet certificate name
then clicking "Save" button.Then check the file "/etc/puppet/puppet.conf", the content of /etc/puppet/puppet.conf
was cleared.


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso        
ovirt-node-3.0.1-3.el6.noarch
ovirt-node-plugin-puppet-3.0.1-3.el6.noarch.rpm



How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:


Additional info:
Comment 5 haiyang,dong 2013-10-27 02:46:55 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch
ovirt-node-tools-3.0.1-6.el6.noarch
ovirt-node-plugin-puppet-3.0.1-6.el6.noarch.rpm

Still met clear /etc/puppet/puppet.conf issue, also this bug blocked Bug 1016393,
Bug 1016386, Bug 988666 to verify. so change "Priority" into "urgent".
Comment 10 haiyang,dong 2013-12-16 03:14:55 EST
Test version:
ovirt-node-3.0.1-9.el6_5.noarch.rpm
rhevh-6.5-20131213.0.0.iso
ovirt-node-plugin-puppet-3.0.1-9.el6_5.noarch.rpm

Test as follow:
Using edit-node install ovirt-node-plugin-puppet into rhevh-6.5-20131213.0.0.iso and clean install this
iso .Login it and enter into puppet page, configure 
Puppet Server:dhcp-10-214.nay.redhat.com
Puppet Certificate Name: dhcp-10-106.nay.redhat.com

after clicking "Save" button to apply this configuration. check that: 
[root@agent2 admin]# cat /etc/puppet/puppet.conf |more
[main]
    server = "dhcp-10-214.nay.redhat.com"
    certname = "dhcp-10-106.nay.redhat.com"
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet
...


so this issue about "clear /etc/puppet/puppet.conf issue" has been fixed,after the status of this bug changed into "ON_QA", i'll verify it.
Comment 11 haiyang,dong 2013-12-16 21:02:48 EST
According to comment 10, change it into "verified".
Comment 12 Cheryn Tan 2014-01-08 00:35:42 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 13 haiyang,dong 2014-01-20 04:38:00 EST
Also this bug was fixed in the follow version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch
ovirt-node-plugin-puppet-3.0.1-16.el6_5.noarch.rpm
Comment 15 errata-xmlrpc 2014-01-21 14:52:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.