Bug 1016382 - hwcert-client no longer logging "Test Parameters"
hwcert-client no longer logging "Test Parameters"
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 01:22 EDT by Yunlong Xue
Modified: 2014-05-21 15:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5-20131210
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1038354 (view as bug list)
Environment:
Last Closed: 2014-05-21 15:18:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch adding <parameters> to <run> to log Test Parameters in XML (2.32 KB, patch)
2013-12-04 19:48 EST, Greg Nichols
no flags Details | Diff
additional patch storing parameters as name/value pairs (4.26 KB, patch)
2013-12-10 10:37 EST, Greg Nichols
no flags Details | Diff

  None (edit)
Description Yunlong Xue 2013-10-08 01:22:41 EDT
hwcert-clinet not prints "Test Parameters" in log, which useful for reviewers.
In v7, "Test Parameters" will be printed in the top of log
such as:
https://hardware.redhat.com/results.cgi?cert_id=1010875&id=288877

While in hwcert-client it disappear, such as:
https://hardware.redhat.com/results.cgi?cert_id=1007347&id=289135

But it is useful for reviewers, sometime, we will grab some info form it.
Comment 1 Greg Nichols 2013-10-08 09:28:18 EDT
This was changed to be printed only in debug modes.   Do we want to restore it in 1.6.5 and.or 1.7.0?
Comment 2 Rob Landry 2013-10-10 14:26:53 EDT
(In reply to Greg Nichols from comment #1)
> This was changed to be printed only in debug modes.   Do we want to restore
> it in 1.6.5 and.or 1.7.0?

Yes, can we put them in a <parameters> tag or similar?  We could then easily control visibility in the catalog if it becomes noisy.
Comment 3 Greg Nichols 2013-11-21 19:33:34 EST
This makes sense.
Comment 4 Greg Nichols 2013-12-04 19:48:18 EST
Created attachment 832907 [details]
patch adding <parameters> to <run> to log Test Parameters in XML
Comment 5 Greg Nichols 2013-12-10 10:37:24 EST
Created attachment 834838 [details]
additional patch storing parameters as name/value pairs
Comment 9 errata-xmlrpc 2014-05-21 15:18:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0532.html

Note You need to log in before you can comment on or make changes to this bug.