Bug 1016413 - Console has about 4 minutes time delay to get application_info of domains after creating applications.
Console has about 4 minutes time delay to get application_info of domains aft...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 02:30 EDT by Yujie Zhang
Modified: 2015-05-14 21:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:23:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2013-10-08 02:30:09 EDT
Description of problem:

Created application for the domains, and checked the domains info from settings page, the info of domains can not be updated without waiting for about 4 minutes, checked the log of accessing my applications page, found that after creating applications, console will not get application_info of domains, log is like following:

2013-10-08 01:53:55.220 [INFO ] Started GET "/app/console/applications" for 203.114.244.88 at 2013-10-08 01:53:55 -0400 (pid:21158)
2013-10-08 01:53:55.223 [INFO ] Processing by ApplicationsController#index as HTML (pid:21158)
2013-10-08 01:53:55.223 [DEBUG] Session contents: {"ticket"=>"0|Xj2pMXdH2YjFUkdjXbgTJcLH2jMkpDuDAnC", "login"=>"yujzhang+devnewtest789@redhat.com", "streamline_type"=>:full, "session_id"=>"57025b57376adc67c864327c3a75023c", "_csrf_token"=>"r0CTZesCr/KUGJzRvvW0nvB6hImrUeXH8MOXmkdkdzg=", "terms"=>true, "api_ticket"=>"9265f97a73be011c8485e4914bb7f35dbf7aa9b83d94bfce82bfc8ce33147c5a", "domain_cache_key_component"=>"1381201765.0357022", "has_sshkey"=>false, "currency_cd"=>"eur", "caps"=>[-1, 16, 16, 2, [:small, :medium], "silver", true]} (pid:21158)
2013-10-08 01:53:55.281 [DEBUG] OpenShift API (53.7ms) get https://localhost:443/broker/rest/applications.json?include=cartridges [ code: 200 ] (pid:21158)
2013-10-08 01:53:55.284 [DEBUG] User has cached keys (pid:21158)
2013-10-08 01:53:55.287 [INFO ] Rendered applications/_footer.html.haml (1.0ms) (pid:21158)
2013-10-08 01:53:55.288 [INFO ] Rendered applications/_account_state.html.haml (0.6ms) (pid:21158)

However, after about 4 minutes, console will get application_info of domains, log is as following:

2013-10-08 01:55:21.179 [INFO ] Started GET "/app/console/applications" for 203.114.244.88 at 2013-10-08 01:55:21 -0400 (pid:21158)
2013-10-08 01:55:21.181 [INFO ] Processing by ApplicationsController#index as HTML (pid:21158)
2013-10-08 01:55:21.182 [DEBUG] Session contents: {"ticket"=>"0|Xj2pMXdH2YjFUkdjXbgTJcLH2jMkpDuDAnC", "login"=>"yujzhang+devnewtest789@redhat.com", "streamline_type"=>:full, "session_id"=>"57025b57376adc67c864327c3a75023c", "_csrf_token"=>"r0CTZesCr/KUGJzRvvW0nvB6hImrUeXH8MOXmkdkdzg=", "terms"=>true, "api_ticket"=>"9265f97a73be011c8485e4914bb7f35dbf7aa9b83d94bfce82bfc8ce33147c5a", "domain_cache_key_component"=>"1381201765.0357022", "has_sshkey"=>false, "currency_cd"=>"eur", "caps"=>[-1, 16, 16, 2, [:small, :medium], "silver", true]} (pid:21158)
2013-10-08 01:55:21.276 [DEBUG] OpenShift API (89.9ms) get https://localhost:443/broker/rest/domains.json?include=application_info [ code: 200 ] (pid:21158)
2013-10-08 01:55:21.289 [DEBUG] OpenShift API (87.8ms) get https://localhost:443/broker/rest/applications.json?include=cartridges [ code: 200 ] (pid:21158)
2013-10-08 01:55:21.291 [DEBUG] User has cached keys (pid:21158)

This issue only happens when creating application, the domains info can be updated immediately from console after deleting appliations.

Version-Release number of selected component (if applicable):
devenv-stage_488

How reproducible:
always

Steps to Reproduce:
1.Create new applications for domains
2.Go to settings page to check the info of the domains
3.

Actual results:

The info of domains can only be updated after about 4 minutes.

Expected results:

The info fo domains should be updated timely.

Additional info:
Comment 1 Jordan Liggitt 2013-10-08 09:14:23 EDT
Due to domains cache... need to clear on:
app create/delete
app scale
cartridge add/remove
member add/remove
Comment 2 Clayton Coleman 2013-10-14 09:59:33 EDT
We don't need this in order to release 34 to production.
Comment 3 Jordan Liggitt 2013-11-11 12:32:17 EST
Will merge in https://github.com/openshift/origin-server/pull/4154
Comment 5 Yujie Zhang 2013-11-12 00:57:53 EST
Tested on INT(devenv_4019), settings page can list application_info of domains immediately after creating/deleting applications from website,rhc or restapi, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.