Bug 1016416 - [RFE] Add --shell option to edit-node
[RFE] Add --shell option to edit-node
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 03:02 EDT by haiyang,dong
Modified: 2014-01-21 14:52 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Enhancement
Doc Text:
A shell option is now available in edit-node to perform manual operations on the hypervisor image while it is open for editing.This was done so end users can script any modifications necessary to their environment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:52:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-10-08 03:02:23 EDT
Description of problem:
For upstream edit-node, it has already support --shell option to edit-node
[root@dhcp-11-127 home]# edit-node --shell rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
Setting SELinux Permissive During Yum Install
Returning SELinux To Enforcing
Launching shell. Exit to continue.
----------------------------------
[root@dhcp-11-127 /]# 

But for downstream edit-node, it still failed to support this case:
# edit-node --shell rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
Usage: 
       edit-node [-n=<name>]
                      [-o <output>]
                      [-w <user,encrypted password>
                      [-l <sshkeyfile>
                      [-t <tmpdir>]
                      [--install-kmod <kmod_pkg_name>
                      [--install-plugin <plugin_name>
                      [--install <pkg_name>
                      [--repo <plugin_repo>
                      <LIVEIMG.src>

edit-node: error: no such option: --shell

so it's better to add --shell option to edit-node.It can give a shell for editing.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso	
ovirt-node-3.0.1-3.el6.noarch
ovirt-node-tools-3.0.1-3.el6.noarch.rpm


How reproducible:
100%

Steps to Reproduce:


Actual results:

Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 21:45:11 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 haiyang,dong 2013-10-26 09:34:01 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch
ovirt-node-tools-3.0.1-6.el6.noarch

Test steps:
[root@dhcp-11-127 home]# edit-node --shell rhevh-6.5-20131024.1.0.iso 
rhevh-6.5-20131024.1.0.iso
Setting SELinux Permissive During Yum Install
Launching shell. Exit to continue.
----------------------------------
[root@dhcp-11-127 /]# exit
exit
Returning SELinux To Enforcing
done
Running Minimizer
..

Now it has add --shell option to edit-node.It can give a shell for editing.

so this bug has been fixed, change it into "VERIFIED".
Comment 8 Cheryn Tan 2013-11-07 19:34:18 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:52:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.