Bug 1016450 - Cache statistics update differently in library and Client-Server mode
Cache statistics update differently in library and Client-Server mode
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER3
: 6.5.0
Assigned To: Vladimir Blagojevic
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 04:15 EDT by Jiri Holusa
Modified: 2015-06-23 08:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-23 08:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-3602 Minor Resolved Cache statistics update differently in library and Client-Server mode 2015-05-04 02:51:55 EDT

  None (edit)
Description Jiri Holusa 2013-10-08 04:15:29 EDT
When running jdg quickstart carmart ( https://github.com/infinispan/jdg-quickstart/tree/master/carmart ) I noticed interesting thing.

When calling replace() in library mode, the number of stores in cache statistics doesn't change whereas when calling in Client-Server mode, the number of stores increase by 1.

I went deeper into the code and I found out that in CacheMgmtInterceptor, where there are implemented methods for such statistics updates (like for put() ), there isn't implemented method for updating stats for replace() method, so the control flow is just passed.

I think it should be consistent, but I don't know which approach is intended, if either increase by 1 or leave it the same.

If increase is the answer than the solution is simple, implement CacheMgmtInterceptor.visitReplaceCommand(...) the same way as e.g. visitPutKeyValueCommand.
Comment 2 JBoss JIRA Server 2015-01-12 06:22:26 EST
Tristan Tarrant <ttarrant@redhat.com> updated the status of jira ISPN-3602 to Resolved

Note You need to log in before you can comment on or make changes to this bug.