Bug 1016468 - node-installer --dns true fails sometimes on starting named service
node-installer --dns true fails sometimes on starting named service
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 04:43 EDT by Ivan Necas
Modified: 2014-04-24 13:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:07:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Necas 2013-10-08 04:43:15 EDT
Description of problem:
There is a dependency issue, where permissions for /etc/rndc.key are set after trying to start named service:

[DEBUG [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  Service[named](provider=service_wait): Executing '/usr/share/node-installer/modules/service_wait/bin/service-wait named start'
[[31mERROR[0m [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  /Stage[main]/Dns/Service[named]/ensure: change from stopped to running failed: Could not start Service[named]: Execution of '/usr/share/node-installer/modules/service_wait/bin/service-wait named start' returned 7:  at /usr/share/node-installer/modules/dns/manifests/init.pp:76
[DEBUG [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  Service[named](provider=service_wait): Executing '/usr/share/node-installer/modules/service_wait/bin/service-wait named status'
[DEBUG [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  /Stage[main]/Dns/Service[named]: Skipping restart; service is not running
[[33m WARN[0m [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  /Stage[main]/Dns/Service[named]: Triggered 'refresh' from 5 events
[[33m WARN[0m [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  /File[/etc/rndc.key]/group: group changed 'root' to 'named'
[[33m WARN[0m [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  /File[/etc/rndc.key]/mode: mode changed '600' to '640'
[[33m WARN[0m [34m2013-10-07 13:31:33[0m [36mpuppet[0m]  /File[/etc/rndc.key]/seluser: seluser changed 'unconfined_u' to 'syst


How reproducible:
Sometimes - puppet ordering issue
Comment 1 RHEL Product and Program Management 2013-10-08 04:57:50 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Ivan Necas 2013-10-10 09:16:51 EDT
Upstream PR opened https://github.com/theforeman/puppet-dns/pull/14
Comment 5 Ivan Necas 2013-10-15 09:23:46 EDT
The upstream PR merged, the update node-installer has version node-installer-0.0.17-1
Comment 8 Corey Welton 2013-10-21 22:30:44 EDT
I still saw this on a muffed install of Snap6 (first compose) when I fat-fingered/mis-pasted node-install parameters, but I will see if I can repro again.
Comment 9 Corey Welton 2013-10-25 12:16:50 EDT
Ehhh, I cannot repro now.  We can reopen if it shows up again. 

QA Verified in Satellite-6.0.2-RHEL-6-20131023.1
Comment 12 Bryan Kearney 2014-04-24 13:07:26 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.