Bug 101649 - can't unmount NFS volume with Stale NFS handle
can't unmount NFS volume with Stale NFS handle
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 03:06 EDT by D. Hugh Redelmeier
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 16:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D. Hugh Redelmeier 2003-08-05 03:06:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030623

Description of problem:
I rebooted an NFS server while my RHL8.0 box had two NFS volumes mounted.  That
should work because NFS is stateless, right?

I'm not trying to unmount the volumes.  umount(8) suggests -f for a situation
related to mine.

As you can see below, mount -f is not working for me.  Is this a bug?  Is there
a way I can solve the problem without rebooting?

[root@redsky hugh]# mount
 ...
redouble:/ on /redouble type nfs (rw,addr=192.139.70.112)
redouble:/home on /redouble/home type nfs (rw,addr=192.139.70.112)
[root@redsky hugh]# umount /redouble/home
umount: /redouble/home: Stale NFS file handle
[root@redsky hugh]# umount -f /redouble/home
umount2: Stale NFS file handle
umount: /redouble/home: Illegal seek
[root@redsky hugh]# umount /redouble/home
umount: /redouble/home: Stale NFS file handle
[root@redsky hugh]# umount -f /redouble/home
umount2: Stale NFS file handle
umount: /redouble/home: Illegal seek
[root@redsky hugh]# /sbin/lsof /redouble/home
bash: /sbin/lsof: No such file or directory
[root@redsky hugh]# /usr/sbin/lsof /redouble/home
lsof: WARNING: can't stat() nfs file system /redouble
      Output information may be incomplete.
lsof: WARNING: can't stat() nfs file system /redouble/home
      Output information may be incomplete.
lsof: status error on /redouble/home: Stale NFS file handle
lsof 4.63
 latest revision: ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/
 latest FAQ: ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/FAQ
 latest man page: ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/lsof_man
 usage: [-?abhlnNoOPRstUvV] [-c c] [+|-d s] [+D D] [+|-f]
 [-F [f]] [-g [s]] [-i [i]] [+|-L [l]] [+|-M] [-o [o]] [-p s]
 [+|-r [t]] [-S [t]] [-T [t]] [-u s] [+|-w] [--] [names]
Use the ``-h'' option to get more help information.
[root@redsky hugh]# 


Version-Release number of selected component (if applicable):
mount-2.11r-10

How reproducible:
Didn't try


Additional info:
Comment 1 Elliot Lee 2004-06-04 16:23:03 EDT
I think part of the problem is that /redouble is also mounted from the
same server and is likely to be stale.

There's no way around this given the present NFS situation. You may be
able to eliminate the possibility by changing the way you mount things
- at first glance it doesn't seem like there's a need for two separate
mounts.

Note You need to log in before you can comment on or make changes to this bug.