Bug 1016504 - Chapter should contain section for every GA release
Chapter should contain section for every GA release
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation, Web Services (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: EAP 6.4.0
Assigned To: sgilda
Jan Blizňák
: Documentation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 05:47 EDT by Petr Sakař
Modified: 2015-10-28 16:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14877, Migration Guide-6.2-1 Build Date: 02-10-2013 13:32:44 Topic ID: 14386-479618 [Latest]
Last Closed: 2015-10-28 16:24:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sakař 2013-10-08 05:47:17 EDT
Title: Web Services Changes

Describe the issue:
Chapter should contain sections for each released version 

Example:
Migration from EAP 5.0.0 to 5.0.1
Migration from EAP 5.0.1 to 5.1.0
Migration from EAP 5.1.0 to 5.1.1
Migration from EAP 5.1.1 to 5.1.2
Migration from EAP 5.1.2 to 5.2.0
Migration from EAP 5.2.0 to 6.0
Migration from EAP 6.0 to 6.0.1
Migration from EAP 6.0.1 to 6.1.0
Migration from EAP 6.1.0 to 6.1.1
Migration from EAP 6.1.1 to 6.2.0

Additional information:
If there are no tasks involved in migration, should be stated so (do not omit the section please)
Comment 1 sgilda 2013-11-01 08:34:45 EDT
This guide is intended for Migration from EAP 5.x to EAP 6.x. I included all the informatio that was available to me at the time. 

Web service changes from one EAP 5 minor release to another EAP 5 minor release would not be documented in the EAP 6 Migration Guide.

Web Services should not change for every EAP 6.x minor release. If it does, someone needs to enter a specific bug for that change and I will be happy to document the change. Otherwise, this is too vague and I am not sure what I can do.
Comment 2 Petr Sakař 2013-11-22 04:38:40 EST
Please read the description carefully first before closing the issue. Nobody is doing migration for 5.x to 6.x, the migration is always from specific version to specific version (eg. 5.1.1 to 6.0.0).
Comment 7 sgilda 2014-03-05 07:26:19 EST
Petr,

First, the Migration Guide is intended to cover migration from previous releases to JBoss EAP 6. The following topics belong in a EAP 5 Migration Guide and should be in a separate bug. They not belong here: 

    Migration from EAP 5.0.0 to 5.0.1
    Migration from EAP 5.0.1 to 5.1.0
    Migration from EAP 5.1.0 to 5.1.1
    Migration from EAP 5.1.1 to 5.1.2
    Migration from EAP 5.1.2 to 5.2.0

I believe the guide currently handles this one. If something is missing, please enter a specific bug for it.

    Migration from EAP 5.2.0 to 6.0

Who can provide me with the details for each of the following? If something changes, I need a specific bug entered for it.

    Migration from EAP 6.0 to 6.0.1
    Migration from EAP 6.0.1 to 6.1.0
    Migration from EAP 6.1.0 to 6.1.1
    Migration from EAP 6.1.1 to 6.2.0
Comment 8 Petr Sakař 2014-03-05 07:47:11 EST
Sande,
great, we are getting further. So the first step is to fix the title, as you suggested, currently is documented migration from 5.2.0 to 6.0.0. 

Then should be added chapter for every version change, even if the migration do not involve any actions, that is important to know as well.

I believe the details for each version can provide Alessio Soldano as project lead for JBossWs (asoldano@redhat.com)

I understand it is a lot of work ATM because of debt of missing information for already existing version, but once it is done, then adding information for every new version is quite straightforward.
Comment 11 sgilda 2014-07-21 08:54:49 EDT
Thanks for the update Alessio!
Comment 12 anrobert 2015-10-28 16:24:08 EDT
The BZ has not been updated for over a year and sgilda continues to work on updates and improvements. Closing this BZ because we're tracking the updates via other JIRAs.

Note You need to log in before you can comment on or make changes to this bug.