Bug 1016507 - Need to submit info twice when edit membership on INT using yujzhang+stg999@redhat.com
Need to submit info twice when edit membership on INT using yujzhang+stg999@r...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jordan Liggitt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 05:56 EDT by Tian Feng
Modified: 2015-05-14 21:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:27:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tian Feng 2013-10-08 05:56:33 EDT
Description of problem:
When editing membership using yujzhang+stg999@redhat.com for the first time, it would return an error "Could not update members.". But can submit it again using the same info.
Have tried other account with larger gear size, but no such error occurs.

Version-Release number of selected component (if applicable):
INT

How reproducible:
Always

Steps to Reproduce:
1. login with yujzhagn+stg999@redhat.com and go to /app/account/domains
2. select a domain, add member, edit the role, and then save
3. after the error, edit membership using the same info, and then save

Actual results:
The first time it would return "Could not update members.". And the second time it would success.

Expected results:
Can edit just once with no error prompt

Additional info:
Comment 1 Jordan Liggitt 2013-10-08 10:29:28 EDT
Any info in the logs?
Comment 3 Tian Feng 2013-10-08 20:52:42 EDT
I have tried other accounts, but only this account and only on INT has this problem. You can verify it with yujzhang+stg999@redhat.com:redhat.
Cause it only occurs on INT, I'm afraid that I can't provide logs for it.
Comment 4 Jordan Liggitt 2013-10-09 10:27:35 EDT
Cannot recreate with yujzhang+stg999@redhat.com on INT.

1. Logged in
2. Went to /app/console/domains
3. Selected a domain
4. Clicked "Edit members..."
5. Clicked "Add another member..."
6. Entered 'jliggitt@redhat.com', changed role to admin
7. Saved

This worked correctly for me every time.
Comment 5 Yujie Zhang 2013-10-09 22:26:10 EDT
Tried on INT using "yujzhang+stg999@rehat.com", can not reproduce this issue now, thanks!

Note You need to log in before you can comment on or make changes to this bug.