Bug 1016526 - edit-node:Better to launch shell before the state of selinux reset back
edit-node:Better to launch shell before the state of selinux reset back
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: Joey Boggs
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 06:14 EDT by haiyang,dong
Modified: 2014-03-31 08:29 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-31 08:29:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19961 None None None Never

  None (edit)
Description haiyang,dong 2013-10-08 06:14:11 EDT
Description of problem:
After execute "edit-node --shell *.iso"
[root@dhcp-11-127 home]# edit-node --shell rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
Setting SELinux Permissive During Yum Install
Returning SELinux To Enforcing
Launching shell. Exit to continue.
----------------------------------
[root@dhcp-11-127 /]# 

we check that edit-node change to permissive on the
build machine if it's enforcing, then reset back.Launching shell in the end

but actually it should launch shell before the state of selinux reset back

Version-Release number of selected component (if applicable):
ovirt-node-tools-3.1.0-0.999.20131008031742gitb12767b.el6.noarch


How reproducible:
100%
 
Steps to Reproduce:


Actual result:


Expect result:

Additional info:
Comment 1 Sandro Bonazzola 2014-01-27 08:50:36 EST
This should be fixed in oVirt 3.4.0 beta1 build
Comment 2 haiyang,dong 2014-03-02 22:01:44 EST
Test version:
ovirt-node-tools-3.0.4-1.0.el6.noarch.rpm

Test result:
edit-node --shell ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso
ovirt-node-iso-3.0.4-1.0.201401291204.el6.iso
Setting SELinux Permissive During Yum Install
Launching shell. Exit to continue.
----------------------------------
[root@dhcp-11-127 /]# exit
exit
Returning SELinux To Enforcing
done
Running Minimizer
[]
Creating Manifests

..

check that edit-node change to permissive on the
build machine if it's enforcing, then it will launch shell, and reset the state of selinux back in the end.
so this bug has been fixed, change the status into "verified".
Comment 3 Sandro Bonazzola 2014-03-31 08:29:05 EDT
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Note You need to log in before you can comment on or make changes to this bug.