Bug 1016614 - RHEV-H 6.5 which is pending floods engine log with error messages
RHEV-H 6.5 which is pending floods engine log with error messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 08:12 EDT by Martin Pavlik
Modified: 2016-02-10 14:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 11:05:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (10.30 MB, application/x-xz)
2013-10-08 08:12 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2013-10-08 08:12:49 EDT
Created attachment 809242 [details]
log_collector

Description of problem:

After installation of RHEVH-6.5 when the host is pending for approval, engine log gets flooded with following messages

2013-10-08 13:31:19,155 ERROR [org.ovirt.engine.core.bll.RegisterVdsQuery] (ajp-/127.0.0.1:8702-2) Query execution failed due to invalid inputs. Invalid OTP for host 10.34.66.51
2013-10-08 13:31:19,155 ERROR [org.ovirt.engine.core.register.RegisterServlet] (ajp-/127.0.0.1:8702-2) Failed to run RegisterVds.


Engine should not try to register VDS until Approve button is clicked.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.24.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. install host with following PXE line adjusted accordingly 

APPEND rootflags=loop initrd=images/RHEVH/rhev-hypervisor6-6.5-20130918.0.el6ev/initrd0.img root=live:/rhevh-latest-6.iso rootfstype=auto ro liveimg nomodeset check rootflags=ro crashkernel=512M-2G:64M,2G-:128M elevator=deadline processor.max_cstate=1 rd_NO_LVM rd_NO_LUKS rd_NO_MD rd_NO_DM console=tty0 console=ttyS1,115200n81 firstboot storage_init=/dev/sda storage_vol=::::: ssh_pwauth=1 adminpw=LMi16hIGAvm0A ntp=10.34.32.125 edd=off rhevm_admin_password=gPA37ATxRODnA management_server=mp-rhevm33.rhev.lab.eng.brq.redhat.com:443
    IPAPPEND 2
2. host appears in rhev-m as pending for approval
3. check engine.log

Actual results:
log is flooded with error messages

Expected results:
log records that there is a host pending for approval

Additional info:
Comment 1 Itamar Heim 2013-10-09 03:27:19 EDT
OTP is for auto approval, not for registration. engine should register the host to show for approval.
Comment 2 Douglas Schilling Landgraf 2013-10-14 17:28:24 EDT
Hi Martin,

I cannot reproduce the report. Here my data:

(NODE) rhev-hypervisor6-6.5-20131011.0
https://brewweb.devel.redhat.com/buildinfo?buildID=299356

RHEVM: 3.3.0-0.25.beta1.el6ev

Test #1:
=============
PXE parameters:
firstboot BOOTIF=eth0 ip=dhcp storage_init=/dev/vda storage_vol=::::: ssh_pwauth=1 adminpw=SA1rUgLR65hIM rhev_admin_password=SA1rUgLR65hIM management_server=192.168.122.9

Node appears on RHEV-M on pending approval status and there is no error flooding in engine.log


Test #2:
===========
Registered manually the node and on pending approval status it doesn't flood the engine.log with errors.

Martin, Am I missing any step? Do you mind to do you test again against 3.3.0-0.25.beta1.el6ev ?

Thanks
Douglas
Comment 3 Martin Pavlik 2013-10-18 11:05:25 EDT
Cannot reproduce log flooding any more with is19 and rhev-hypervisor6-6.5-20131011.0, closing as current release

Note You need to log in before you can comment on or make changes to this bug.