Bug 1016636 - [RHEVM][webadmin] remove VM network checkbox from manage network dialog
[RHEVM][webadmin] remove VM network checkbox from manage network dialog
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.4
x86_64 Linux
medium Severity low
: ---
: 3.4.1
Assigned To: Alona Kaplan
Martin Pavlik
network
: UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 08:58 EDT by Martin Pavlik
Modified: 2014-05-08 09:35 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 09:35:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (163.06 KB, image/png)
2013-10-08 08:59 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 24830 None None None Never
oVirt gerrit 25386 None MERGED webadmin: Manage network dialog- replace VM network checkbox with icon Never

  None (edit)
Description Martin Pavlik 2013-10-08 08:58:58 EDT
Description of problem:
It does really not make sense to have VM Network checkbox in the middle of Manage network dialog.

1) it is confusing because all the checkboxes look the same (in unchecked state)  and 4 of 5 can be changed, just the VM network is not interactive (because VM network is property set per network, not per cluster)

2) VM network checkbox as indicator of network role is redundant since user can see network role icon in background on Networks main tab


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.24.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. create new network
2. pick the new network and go to Clusters sub-tab
3. click manage networks (see screenshot)

Actual results:
VM network checkbox is confusing for the user

Expected results:
Remove VM network checkbox form Manage Network dialog or at least make it clear for user that this checkbox is not interactive

Additional info:
Comment 1 Martin Pavlik 2013-10-08 08:59:25 EDT
Created attachment 809265 [details]
screenshot 1
Comment 2 Martin Pavlik 2013-10-09 04:42:47 EDT
Suggestion for change:

Replace VM network checkbox with green vm icon which is shown under Role column in main tab Netwoks.

VM network = True => green VM icon is shown
VM network = False => no icon is show

In my opinion this would make it clear for the user that this field is not to be changed in this dialog window.
Comment 3 Sandro Bonazzola 2014-05-08 09:35:11 EDT
This is an automated message

oVirt 3.4.1 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.