Bug 1016642 - raytrace problems
raytrace problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: satyr (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Milata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 09:09 EDT by Frank Murphy
Modified: 2013-11-28 09:28 EST (History)
8 users (show)

See Also:
Fixed In Version: satyr-0.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 09:28:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2013-10-08 09:09:13 EDT
Description of problem: cannot upload kerneloopses


Version-Release number of selected component (if applicable):


How reproducible: past 10 kerneloopses


Steps to Reproduce:
1. from my pc try report kernel oops
2. using kernel-debug-*
3.

Actual results: Today


1:  (one time)
--- Running report_uReport ---
Server responded with an error: 'Validation failed: error validating 'installed_package': error validating 'architecture': string "x86_64+debug" contains illegal characters'

--- Running report_Bugzilla ---
Essential element 'component' is missing, can't continue
('report_Bugzilla' exited with 1)


2: (9 times)

--- Running report_uReport ---
Server responded with an error: 'Invalid JSON file'

--- Running report_Bugzilla ---
Essential element 'component' is missing, can't continue
('report_Bugzilla' exited with 1)
Comment 1 Frank Murphy 2013-10-08 09:10:38 EDT
Versions:
abrt-desktop-2.1.7-1.fc20.x86_64
abrt-addon-python-2.1.7-1.fc20.x86_64
abrt-plugin-bodhi-2.1.7-1.fc20.x86_64
abrt-2.1.7-1.fc20.x86_64
abrt-gui-libs-2.1.7-1.fc20.x86_64
abrt-addon-kerneloops-2.1.7-1.fc20.x86_64
abrt-retrace-client-2.1.7-1.fc20.x86_64
abrt-java-connector-1.0.6-1.fc20.x86_64
abrt-addon-ccpp-2.1.7-1.fc20.x86_64
abrt-dbus-2.1.7-1.fc20.x86_64
abrt-addon-xorg-2.1.7-1.fc20.x86_64
abrt-addon-vmcore-2.1.7-1.fc20.x86_64
abrt-gui-2.1.7-1.fc20.x86_64
abrt-libs-2.1.7-1.fc20.x86_64
abrt-addon-pstoreoops-2.1.7-1.fc20.x86_64
Comment 2 Jiri Moskovcak 2013-10-08 14:07:57 EDT
Are you running the official kernel from the fedora repository? Please provide the output of the following commands:

uname -a
rpm -q kernel
Comment 3 Frank Murphy 2013-10-08 17:23:56 EDT
(In reply to Jiri Moskovcak from comment #2)
> Are you running the official kernel from the fedora repository? Please
> provide the output of the following commands:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=4456086

> 
> uname -a

Linux torrent.frankly3d.home 3.11.3-301.fc20.x86_64+debug #1 SMP Thu Oct 3 00:43:32 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

> rpm -q kernel

rpm -q kernel
package kernel is not installed

rpm -q kernel-debug
 rpm -q kernel-debug
kernel-debug-3.11.3-301.fc20.x86_64

it is official kernel with debug switched on,
was trying to diagnose kernel problem(s)
Comment 4 Jiri Moskovcak 2013-10-09 02:33:13 EDT
Thanks, that's exactly the info we needed. reassigning to satyr because it's responsible for parsing the kernel version.
Comment 5 Martin Milata 2013-10-09 09:30:44 EDT
Since version 0.10 (commit 69bcefae51f8db7f8200510421044c2a423a083b), satyr takes parsed kernel version from ABRT. The logic for finding out the kernel package is not robust enough to handle kernel-debug package. I've sent patch to change it: https://github.com/abrt/abrt/pull/725

Frank: if you have time, can you please test it with satyr-0.10 from koji [1] and abrt-action-save-kernel-data script from [2]?

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=469764
[2] http://mmilata.fedorapeople.org/abrt-action-save-kernel-data
Comment 6 Frank Murphy 2013-10-09 10:09:54 EDT
(In reply to Martin Milata from comment #5)
> Since version 0.10 (commit 69bcefae51f8db7f8200510421044c2a423a083b), satyr
> takes parsed kernel version from ABRT. The logic for finding out the kernel
> package is not robust enough to handle kernel-debug package. I've sent patch
> to change it: https://github.com/abrt/abrt/pull/725
> 
> Frank: if you have time, can you please test it with satyr-0.10 from koji
> [1] and abrt-action-save-kernel-data script from [2]?
> 
> [1] http://koji.fedoraproject.org/koji/buildinfo?buildID=469764
> [2] http://mmilata.fedorapeople.org/abrt-action-save-kernel-data

Upped a kernel-debug bz with them, please ignore. was just a practical test.

Note You need to log in before you can comment on or make changes to this bug.