Bug 1016643 - [firstboot] Subscription_manager register screens missing on rhel 7 firstboot
[firstboot] Subscription_manager register screens missing on rhel 7 firstboot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Adrian Likins
John Sefler
: TestBlocker
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-08 09:15 EDT by Rehana
Modified: 2014-06-17 20:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:14:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstbootscreen (288.69 KB, image/png)
2013-10-08 09:16 EDT, Rehana
no flags Details
firstboot screen sequence (284.04 KB, image/png)
2013-10-17 17:45 EDT, Sharath Dwaral
no flags Details
Can't be dismissed (51.70 KB, image/png)
2013-10-29 05:21 EDT, Radek Bíba
no flags Details

  None (edit)
Description Rehana 2013-10-08 09:15:17 EDT
Description of problem:
Installed and configured latest rehl7 compose, observed that the firstboot screens doesnt give options to register on subscription_manager

Version-Release number of selected component (if applicable):
rpm -qa | grep subsc
subscription-manager-migration-1.10.3-1.git.0.c59a391.el7.x86_64
subscription-manager-1.10.3-1.git.0.c59a391.el7.x86_64
subscription-manager-gui-1.10.3-1.git.0.c59a391.el7.x86_64
subscription-manager-firstboot-1.10.3-1.git.0.c59a391.el7.x86_64
subscription-manager-migration-data-2.0.4-1.git.0.6bebf6f.el7.noarch
[root@localhost ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.8.29-1
subscription-manager: 1.10.3-1.git.0.c59a391.el7
python-rhsm: 1.10.3-1.git.0.6ac2883.el7


How reproducible:
3/3

Steps to Reproduce:
1.Launch firstboot on rhel7 machine
2.
3.

Actual results:
Observed that no subscription_manager register screens were present (PFA)

Expected results:
firstboot should have subscription_manager register screens

Additional info:
Comment 1 Rehana 2013-10-08 09:16:18 EDT
Created attachment 809277 [details]
firstbootscreen
Comment 3 Carter Kozak 2013-10-17 10:21:16 EDT
commit 77def35b6e10129f8a7225ca1cf155bb681bc335
Author: Devan Goodwin <dgoodwin@redhat.com>
Date:   Thu Oct 17 10:13:39 2013 -0300

    Fix firstboot module location on EL6.

commit 9ebbf0b4b2aaf8cfc3c5f416d2c6640566a8e253
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Oct 15 16:24:17 2013 -0400

    Fix firstboot issues with new firstboot.
    
    Since we now run last in firstboot, we were hitting
    a case where the threads for the subscription api
    calls were not finishing before we stop checking
    the idle loop for events (which in this case, were
    the idle source thread watcher methods).
    
    Also handle no rhn-client-tool modules being installed,
    and skip the steps that rely on them.

commit 03536843f8a6c3a47f660785d86a22cd1d434fb0
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Oct 14 12:13:26 2013 -0400

    Firstboot modules were installing into rhn dirs.
    
    For RHEL6, we were installing firstboot modules into
    the rhn client directories, because of interdependecies
    between the rhn and rhsm modules. Now those are removed,
    so we install to the normal firstboot module dir
    (/usr/share/firstboot/modules).
Comment 5 Sharath Dwaral 2013-10-17 17:45:42 EDT
Created attachment 813560 [details]
firstboot screen sequence

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.4-1.el7
python-rhsm: 1.10.3-1.el7


if  "/etc/sysconfig/firstboot" file exists edit "RUN_FIRSTBOOT=YES"
else  "# firstboot"  in terminal


Firstboot for RHEL7 is working. Please see attahment

VERIFIED
Comment 6 Radek Bíba 2013-10-29 05:21:05 EDT
Created attachment 817029 [details]
Can't be dismissed

Not sure what's wrong, but here's what I see on my system. There's no way to dismiss the dialog. What gives?

If I try clicking Forward with no account information entered, I get an alert saying You must enter a login.
Comment 7 Rehana 2013-10-29 05:26:33 EDT
Radek,

Bug https://bugzilla.redhat.com/show_bug.cgi?id=1021013 was logged to address this issue.

Hope this helps.

Rehana
Comment 8 Radek Bíba 2013-10-29 05:31:44 EDT
Thanks Rehana, I've added myself to the cc list in the new bug.
Comment 9 Ludek Smid 2014-06-13 06:14:35 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.