Bug 1016689 - Test Scenario: new rules are ignored until refresh
Test Scenario: new rules are ignored until refresh
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER6
: 6.0.0
Assigned To: Toni Rikkola
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 10:21 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-10-08 10:21:43 EDT
Description of problem:
Newly created rules don't fire in an already existing Test Scenario. Page refresh and clicking Build & Deploy in the Project Editor help.


Version-Release number of selected component (if applicable):
BPMS 6.0 ER3


Steps to Reproduce:
1. Create a Guided Rule 'gr1', don't add anything.
2. Create a Test Scenario.
3. Create a Guided Rule 'gr2', don't add anything.
4. In the TS, expect both rules to fire, save.
5. Run the TS.


Actual results:
"There were test failures" due to "Rule [gr2] was not activated". The first rule, 'gr1' was fired, the second; 'gr2' was not.


Expected results:
Success. Both rules were fired.
Comment 3 Zuzana Krejčová 2013-10-23 07:30:59 EDT
In ER4, the behaviour changed. Guided rule created before a TS doesn't get fired in the TS until page refresh as well. Furthermore, I cannot get rules from Guided Decision Table to fire until I build the project, simple page refresh doesn't work.
Comment 4 Zuzana Krejčová 2014-01-07 12:24:54 EST
Verified with ER7.

Note You need to log in before you can comment on or make changes to this bug.