Bug 1016714 - After giving abrt notification my root password, only option it gives is 'ignore forever'
After giving abrt notification my root password, only option it gives is 'ign...
Status: CLOSED DUPLICATE of bug 994746
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 10:54 EDT by Cole Robinson
Modified: 2016-11-30 19:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 11:02:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2013-10-08 10:54:44 EDT
I hit a qemu crasher via libvirt. I'm triggering this with virt-manager and polkit auth as root. I get a little notification that qemu crashed, 'ignore' or 'report'. I hit 'report'

Since qemu is launched as the qemu:qemu user and not my regular user, abrt asks for the root password to view other users traces. I enter the root password. Couple seconds go by, and a new notification appears for the same crash.

The problem is the only option it gives me is 'ignore forever'. I want to 'report' it. I can work around it by launching gnome-abrt but understandably I don't want to do that manually.

I saw this on F19 as well with qemu/libvirt crashes, but I can reproduce at will on f20.

Let me know if I can provide any more info
Comment 1 Jakub Filak 2013-10-11 10:35:36 EDT
Thank you for the report. I guess your desktop environment is GNOME and this strange behaviour is caused by Shortened reporting. Please open ABRT GUI -> Application menu -> ABRT Configuration and check state of a switch for Shortened reporting option.
Comment 2 Cole Robinson 2013-10-11 10:39:31 EDT
Shortened reporting is 'on'
Comment 3 Jakub Filak 2013-10-11 11:02:46 EDT
Shortened reporting is enabled by default in GNOME. We had an requirement to make reporting really simple, therefore GNOME users reports to ABRT server only [1]. Disable Shortened reporting and Report button will report a bug to Bugzilla next time.

Closing as DUPLICATE because this issues has already been reported, but please feel free to report any further bugs you find.


1: https://abrt.fedoraproject.org/

*** This bug has been marked as a duplicate of bug 994746 ***

Note You need to log in before you can comment on or make changes to this bug.