Bug 1016726 - livemedia-creator need a device pointing to the original live image
livemedia-creator need a device pointing to the original live image
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On: 1009710
Blocks: 1009711 1018982
  Show dependency treegraph
 
Reported: 2013-10-08 11:09 EDT by Harald Hoyer
Modified: 2013-10-14 16:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: dracut-034-7.git20131008.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1009710
Environment:
Last Closed: 2013-10-12 00:34:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2013-10-08 11:09:11 EDT
+++ This bug was initially created as a clone of Bug #1009710 +++

This is similar to the reason for adding the /run/initramfs/live-baseloop symlink -- access to the original live image without overlays.

livemedia-creator does not create a osmin.img, so there is no mountable device for it to use when rsyncing the live image to the target. It needs a device that points to the original live image without overlays.

Note that lmc won't be creating osmin.img, since really isn't needed any longer. Its purpose was to provide a minimal image that could be dd'd to the target. Now that we use rsync this is no longer necessary.

The included patch adds a /dev/mapper/live-base device that Anaconda can use whether or not there is an osmin present.

This change should also go into F20 and rawhide.

--- Additional comment from Brian C. Lane on 2013-09-18 19:52:26 EDT ---
Comment 1 Fedora Update System 2013-10-08 11:27:15 EDT
dracut-034-7.git20131008.fc20,bcache-tools-0-0.14.20130909git.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-034-7.git20131008.fc20,bcache-tools-0-0.14.20130909git.fc20
Comment 2 Fedora Update System 2013-10-09 10:39:16 EDT
Package dracut-034-7.git20131008.fc20, bcache-tools-0-0.14.20130909git.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-034-7.git20131008.fc20 bcache-tools-0-0.14.20130909git.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18560/dracut-034-7.git20131008.fc20,bcache-tools-0-0.14.20130909git.fc20
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-10-12 00:34:58 EDT
dracut-034-7.git20131008.fc20, bcache-tools-0-0.14.20130909git.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.