Bug 1016755 - SW selection fails to refresh when you change installation ISO
SW selection fails to refresh when you change installation ISO
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 11:55 EDT by Tomas Capek
Modified: 2014-07-18 14:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-18 14:48:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Capek 2013-10-08 11:55:00 EDT
anaconda 19.31.21-1


Steps to Reproduce:
1. Select an ISO file in the Installation Source spoke, for example one for Workstation
2. Click Done, go to the Software Selection spoke, review the environments and add-ons
3. Go back to the Installation Source spoke, select a different ISO, for example one for Server
2. Go to the Software Selection spoke again, review the environments and add-ons


Actual results:

The list of environments and add-ons is not updated

Expected results:

Refresh contents of an ISO file properly every time an ISO file is loaded, possibly even an image with identical name but in a different folder etc.
Comment 1 Chris Lumens 2014-03-13 15:39:38 EDT
Please retest with a snapshot release if possible.  There are multiple commits since this bug was reported that mention refreshing the software spoke, so it's very possible we have fixed this problem.  Thanks.
Comment 2 Tomas Capek 2014-03-17 11:39:13 EDT
I checked it in 19.31.68-1

The scenario as described above seems to be fixed. When a source (a different ISO in this case) is changed, a warning appears at the SW Selection spoke: "Source changed - please verify"

However, I found a couple of other issues:

i) When I set up a first inst. source, the SW selection spoke displayed a warning "Nothing selected". But when I clicked the spoke, "Minimal install" was selected.

ii) I've got two ISOs in one directory (Server,Workstation). When I switch between them in the Inst. Source spoke, I consistently get the "Error setting up ISO file" subtitle message, which is black rather than red. However, the SW selection spoke updates as expected.

Then, if I go back to select an ISO, the label of the "Choose an ISO" button is blank. When I click the button and select the same ISO file and click Done, then the message changes to the name of the ISO file as expected.
Comment 3 David Cantrell 2014-07-18 14:48:28 EDT
Closing per comment #2.  Original problem resolved.  New problems require new bug reports.

Note You need to log in before you can comment on or make changes to this bug.