Bug 1016861 - Starting the RHEV Spice Agent on the Windows VM, results in the guest in a hung state.
Starting the RHEV Spice Agent on the Windows VM, results in the guest in a hu...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-vdagent-win (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 16:16 EDT by Bill Sanford
Modified: 2013-12-12 11:13 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 11:13:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-10-08 16:16:54 EDT
Description of problem:
Install the tools-ISO from rhev-guest-tools-iso-3.3-6.noarch.rpm on the Windows guest. Then you restart the guest from the install.

At this point, the RHEV Spice Agent should be automatically started but it's not and it needs to be turned on in Windows "Services." Once you "Start" the service on the guest, the VM hangs.

At this hang of the VM, if you force the VM off and restart it, the RHEV Spice Agent is now working and the RHEV Spice Agent is now starting automatically.

Version-Release number of selected component (if applicable):
RHEL6.5-20130925.2
Windows & and XP VMs
rhev-guest-tools-iso-3.3-6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Christophe Fergeau 2013-10-09 05:13:37 EDT
Would be interesting to have some logs from the tool installer and from vdagent right after installation. 'the VM hangs' makes me suspect a virtio-serial bug rather than an agent one.
Comment 2 Christophe Fergeau 2013-10-09 07:59:40 EDT
For what it's worth, I just tried to install rhev-guest-tools-iso-3.3-6.noarch.rpm on a RHEL6 host with qemu-kvm-rhev-0.12.1.2-2.406.el6.x86_64 and spice-server-0.12.4-3.el6.x86_64 in a win7sp1 32 bit guest. Arbitrary resolution and c&p between host and guest worked as soon as the installation finished, even without a reboot. After a reboot, the agent is still running.
In short, I could not reproduce this, not sure what difference causes this to trigger in your setup.
Comment 3 Bill Sanford 2013-10-09 09:54:10 EDT
I am running Windows 8.1 for a client.
Comment 4 Christophe Fergeau 2013-10-11 08:09:08 EDT
I tried with a win7 client just in case, and could not reproduce either. How are you creating the VM? Can you give exact name/version number of all components involved? (qemu-kvm and spice-server are likely to be the most interesting ones). Did you manage to reproduce this multiple times?
Comment 5 David Blechter 2013-12-09 12:55:54 EST
can you provide the answer on the above questions? 
I think that the access to this specific VM will help as well.
Comment 7 Bill Sanford 2013-12-12 11:13:02 EST
I am not seeing this in RHEV-M 3.3 (is26). I will reopen if this is a problem.

Note You need to log in before you can comment on or make changes to this bug.