Bug 1016929 - New Sat Cert tool (in RHSM-Web) needs user friendly / helpful errror message instead of Internal Server Error (ISE)
New Sat Cert tool (in RHSM-Web) needs user friendly / helpful errror message ...
Status: CLOSED DEFERRED
Product: Red Hat Customer Portal
Classification: Red Hat
Component: Subscriptions/RHSM (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: Backlog
: ---
Assigned To: Thomas "Shea" DeAntonio
Jon Allen
:
Depends On:
Blocks: 1289374
  Show dependency treegraph
 
Reported: 2013-10-08 20:20 EDT by Xixi
Modified: 2015-12-15 16:38 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 15:52:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2013-10-08 20:20:39 EDT
Description of problem:
Customer tries to generate Satellite cert with new tool and got Internal Server Error

"The server experienced a problem which prevented your request from being filled out. It may not be possible to execute this action at this time.

Please help us correct this problem by contacting us with details of how you received this message."

In customer's words: "A more informative message would have been nice. I wouldn't have bothered you."

This was a one-day occurrence however a more user-friendly message showing actual root cause would be more useful to customers, support and developers in figuring out the problem / troubleshooting.

The RHN Classic sat cert tool handled error messages better, if I remember correctly.

Version-Release number of selected component (if applicable):
current

How reproducible:
not anymore and it was uncertain the cause of the error to really replicate, more reason to have a clear message :)

Steps to Reproduce:
1. Try to generate a Satellite cert via new Sat cert tool under Satellite tab from https://access.redhat.com/management/distributors/
2. Have some sort of problem that would throw an exception
3.

Actual results:
ISE

Expected results:
user-friendly error message showing root cause

Additional info:
Comment 2 Xixi 2013-10-08 20:26:51 EDT
(In reply to comment #0)
> How reproducible:
> not anymore and it was uncertain the cause of the error to really replicate,
> more reason to have a clear message :)
> 
Found this in case update: 
"your new entitlements begin tomorrow and are unavailable for certificate generation today.  Please try again tomorrow, and let me know how that goes."
...
so one possible way to replicate is to use an account that doesn't have the necessary entitlements yet.

But again, the tool needs to handle exceptions better and display a friendly/informative message instead of Internal Server Error.

Note You need to log in before you can comment on or make changes to this bug.