Bug 101695 - MySQL 4.0.14 crashes at install (of either rpm or tar)
MySQL 4.0.14 crashes at install (of either rpm or tar)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mysql (Show other bugs)
3.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-05 13:26 EDT by Eric Raymond
Modified: 2013-07-02 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 16:07:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Raymond 2003-08-05 13:26:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030617

Description of problem:
Using the rpms or the tar file from mysql.com fails during installation.

....

Installing all prepared tables
/usr/bin/mysql_install_db: line 1:  7690 Segmentation fault     
/usr/sbin/mysqld --bootstrap --skip-grant-tables --basedir=/
--datadir=/var/lib/mysql --skip-innodb --skip-bdb
Installation of grant tables failed!


Version-Release number of selected component (if applicable):
4.0.14

How reproducible:
Always

Steps to Reproduce:
1. Goto mysql.com
2. Get MySQL-server-4.0.14-0.i386.rpm and MySQL-client-4.0.14-0.i386.rpm (or
alternately get the binary tar ball)
3. rpm -Uvh MySQL-server-4.0.14-0.i386.rpm MySQL-client-4.0.14-0.i386.rpm


... Boom

Actual Results:  Boom.  Installation fails partway through.  Cannot run mysqld!

Expected Results:  Sucessful installation. Should be able to run mysql server.

Additional info:
Comment 1 Patrick Macdonald 2003-08-11 12:28:49 EDT
We do not support MySQL 4.0 at the moment (due to license conflicts between the
client libraries and other packages).  However, we did have MySQL 4.0.12
building  and running for short while before reverting back to 3.23.  

I will build MySQL 4.0 on the Taroon beta later this week (just got back from
vacation so there is a lot on my plate) and update the bug accordingly.  

Did you attempt to rebuild the rpm from source on Taroon?  If so, did it still fail?
Comment 2 Eric Raymond 2003-08-11 13:12:17 EDT
I did not try to rebuild the RPM from source.

FYI, I care less that the MySQL rpm's come RedHat (licensing) than that the
latest RPM from MySQL works (compatability).
Comment 3 Patrick Macdonald 2003-08-12 16:14:31 EDT
Ok... downloaded the MySQL packages from mysql.com.  Made sure I had the 
correct perl-DBD, perl-DBI and perl-CGI packages installed.  Since the 
perl packages are linked against mysql-3.23 (which has mysqlclient.so.10), I
created a mysqlclient10 package to install this file.  The mysqlclient in 
the 4.0.14 package is mysqlclient.so.12.  

Here's the output of my install...

--- begin install 

[root@toledo patrickm]# rpm -Uvh MySQL-server-4.0.14-0.i386.rpm MySQL-client-4.0
.14-0.i386.rpm
warning: MySQL-server-4.0.14-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f
5
Preparing...                ########################################### [100%]
   1:MySQL-client           ########################################### [ 50%]
   2:MySQL-server           ########################################### [100%]
Installing all prepared tables
030812 15:47:35  /usr/sbin/mysqld: Shutdown Complete


PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
This is done with:
/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h toledo password 'new-password'
See the manual for more instructions.

NOTE:  If you are upgrading from a MySQL <= 3.22.10 you should run
the /usr/bin/mysql_fix_privilege_tables. Otherwise you will not be
able to use the new GRANT command!

Please report any problems with the /usr/bin/mysqlbug script!

The latest information about MySQL is available on the web at
http://www.mysql.com
Support MySQL by buying support/licenses at https://order.mysql.com

Starting mysqld daemon with databases from /var/lib/mysql

---- end of install

So the problem could be that your system does not have the required
perl packages installed or that the MySQL access methods in the Taroon
beta are linked against mysqlclient.10 not 12 (which is provided in the
MySQL.com packages) which is causing the MySQL.com supplied packages to
fail on install.  
Comment 4 Eric Raymond 2003-08-13 14:53:19 EDT
This advice came a bit too late for me to verify (we downgraded the OS on this
machine to ES 2.1).

So what you're saying is that the problem is MySQL's to resolve, not RedHat's?
FYI, I just got email saying that some experienced a similar problem under Red
Hat (severn) 9.0.93.
Comment 5 Patrick Macdonald 2003-08-13 15:12:09 EDT
The MySQL rpms work, it's just that the assumption as to what is underneath it
is not correct at the moment.  I mentioned that I had to install the back level
MySQL client to get the install to work.  Both Taroon and Severn are built with
the MySQL 10 libraries, the new MySQL provides 12.

This will be rectified once Red Hat moves to MySQL 4.0 but that is in the 
hands of the MySQL license folks at the moment.  I would be an interesting
exercise to download the (hopefully) provided mysqlclient10 rpm from MySQL.com
and install it along with the MySQL-server and MySQL-client.  This is what I
did, using Red Hat rpms, and the install succeeded. 
Comment 6 Eric Raymond 2003-08-13 15:32:01 EDT
Hmmm.  Yet another argument for giving the user/installer fine grain control
over what packages are installed.  FYI, I'm pretty sure I removed all the rpm's
matching mysql....

Thanks and good luck
Comment 8 Tom Lane 2004-12-08 16:07:53 EST
AFAICS this bug essentially complains that the 4.0 RPMs provided by
MySQL AB are wrong --- that is, they are missing a dependency.  So
it's not within our power to fix.  In any case, as of RHEL4 we will be
shipping MySQL 4.1, making packaging issues with 4.0 rather moot.  I'm
going to close this as WONTFIX, barring evidence of any similar
mistake in our own packaging of 4.1.

Note You need to log in before you can comment on or make changes to this bug.