Bug 1016952 - qemu-kvm man page guide wrong path for qemu-bridge-helper
qemu-kvm man page guide wrong path for qemu-bridge-helper
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 23:00 EDT by Xu Han
Modified: 2015-05-24 20:07 EDT (History)
8 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-20.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:18:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xu Han 2013-10-08 23:00:57 EDT
Description of problem:
qemu-kvm man page guide wrong path for qemu-bridge-helper.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-7.el7.x86_64

How reproducible:


Steps to Reproduce:
1.open man page and find string 'qemu-bridge-helper'
2.
3.

Actual results:
If running QEMU as an unprivileged user, use the network helper
helper to configure the TAP interface. The default network helper
executable is /usr/local/libexec/qemu-bridge-helper.

Expected results:
The default path is /usr/libexec.

Additional info:
Comment 2 Amos Kong 2013-10-14 02:00:05 EDT
[root@amosk qemu]# ls /usr/local/libexec/qemu-bridge-helper -l
-rwxr-xr-x 1 root root 24198 Oct 14 13:58 /usr/local/libexec/qemu-bridge-helper


qemu-bridge-helper will be truly installed to '/usr/local/libexec/', it's expected, so not a bug of manpage
Comment 4 Amos Kong 2013-10-14 12:05:52 EDT
qemu-bridge-helper of rhel7 is not consistent with manpage.
Better to update redhat/qemu-kvm.spec to make it same as upstream.
Comment 6 Amos Kong 2013-10-22 08:47:55 EDT
The DEF() C macro in this file uses DEFAULT_BRIDGE_HELPER.  In texi mode
the C preprocessor is not used so DEFAULT_BRIDGE_HELPER is not
available.

upstream needs to be fixed.
Comment 7 Amos Kong 2013-10-28 12:32:21 EDT
Posted another fix to upstream:
http://lists.nongnu.org/archive/html/qemu-devel/2013-10/msg02908.html
Comment 10 Miroslav Rezanina 2013-11-28 02:35:46 EST
Fix included in qemu-kvm-1.5.3-20.el7
Comment 12 Xu Han 2013-12-09 04:02:39 EST
Verify this bug with component:
qemu-kvm-1.5.3-21.el7.x86_64

Steps:
1. check patch.
# rpm -q qemu-kvm --changelog | grep '1016952'

2. check string 'qemu-bridge-helper' in man page.
# man qemu-kvm | grep 'qemu-bridge-helper'

Results:
after step1,
# rpm -q qemu-kvm --changelog | grep 1016952
- kvm-doc-fix-hardcoded-helper-path.patch [bz#1016952]
- Resolves: bz#1016952

after step2,
# man qemu-kvm | grep 'qemu-bridge-helper'
           executable is /path/to/qemu-bridge-helper.
                   -net nic -net tap,"helper=/path/to/qemu-bridge-helper"
           /path/to/qemu-bridge-helper and the default bridge device is br0.

Base on these test results above, this bug has been fixed.
Comment 14 Ludek Smid 2014-06-13 05:18:52 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.