Bug 1016956 - Some error messages are given out when executing "oo-diagnostics" on broker
Some error messages are given out when executing "oo-diagnostics" on broker
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 23:33 EDT by Ma xiaoqiang
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: rubygem-openshift-origin-common-1.17.2.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-04 11:57:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-10-08 23:33:04 EDT
Description of problem:
Some error messages are given out when executing "oo-diagnostics" 

Version-Release number of selected component (if applicable):
puddle:[2.0/2013-10-08.1] 
http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/2.0/2013-10-08.1


How reproducible:
always

Steps to Reproduce:
1.Run the following command on broker\
#oo-diagnostics -v -w 1


Actual results:
Output:
INFO: running: test_broken_httpd_version
INFO: running: test_usergroups_enabled
INFO: skipping test_usergroups_enabled
INFO: running: test_mcollective_context
INFO: skipping test_mcollective_context
INFO: running: test_mcollective_bad_facts
INFO: running: test_auth_conf_files
INFO: running: test_broker_certificate
WARN: test_broker_certificate
Using a self-signed certificate for the broker
FAIL: rescue in block in run_tests
error running test_broker_certificate: #<NoMethodError: undefined method `scan' for nil:NilClass>
INFO: running: test_abrt_addon_python
INFO: skipping test_abrt_addon_python




Expected results:
Don't show this error.

Additional info:
This problem didn't happen on ose-1.2.z
Comment 2 Luke Meyer 2013-12-23 12:20:32 EST
test_broker_certificate should be improved now and not result in this error.
Comment 3 Ma xiaoqiang 2013-12-23 19:53:02 EST
check on rubygem-openshift-origin-common-1.17.2.4-1.el6op.noarch
# oo-diagnostics 
<--snip-->
WARN: test_broker_certificate
Using a self-signed certificate for the broker
WARN: test_yum_configuration
        oo-admin-yum-validator reported some possible problems
        with your package source configuration:
--------------------------------------------------------------
      No roles have been specified. Attempting to guess the roles for this system...
If the roles listed below are incorrect or incomplete, please re-run this script with the appropriate --role arguments
    broker
    client
Detected OpenShift Enterprise repository subscription managed by Red Hat Subscription Manager.
Detected installed OpenShift Enterprise version 2.0

Checking if yum-plugin-priorities is installed
Checking channel/repository priorities
Resolving repository/channel/subscription priority conflicts
To resolve conflicting repositories, update repo priority by running:
# yum-config-manager --setopt=openshift_node.priority=40 openshift_node --save
# yum-config-manager --setopt=openshift_infrastructure.priority=40 openshift_infrastructure --save
Please re-run this tool after making any recommended repairs to this system

--------------------------------------------------------------
        Incorrect package source configuration could lead to
        failure to install the correct RPMs.
Comment 4 Miciah Dashiel Butler Masters 2013-12-30 10:09:26 EST
Luke, did you mean to change the product version for this bug report from 1.2.0 to 2.0.0? I'm confused because it looks like you opened bug 1040647 to address the same bug in 2.0.
Comment 5 Luke Meyer 2013-12-31 08:36:23 EST
I changed it because the report was against a 2.0 puddle. I don't recall seeing this under 1.2, not sure what we changed about the config for 2.0 to start running into this. The bug 1040647 *is* a duplicate, I just didn't notice I guess. Is there a need to look at this for 1.2 as well? The fix should be easy...
Comment 6 Luke Meyer 2014-01-02 10:41:15 EST
Actually, I'm going to make a bug for 1.2 because I think it does happen there too.

Note You need to log in before you can comment on or make changes to this bug.