Bug 1016968 - ovirt-engine-dwh logs errors for attribute with more than 255 characters
ovirt-engine-dwh logs errors for attribute with more than 255 characters
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.2.0
All Linux
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Yaniv Lavi (Dary)
Barak Dagan
infra
: ZStream
Depends On:
Blocks: 1017726
  Show dependency treegraph
 
Reported: 2013-10-09 00:56 EDT by Jaison Raju
Modified: 2016-02-10 14:38 EST (History)
9 users (show)

See Also:
Fixed In Version: rhevm-dwh-3.3.0-15.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1017726 (view as bug list)
Environment:
Last Closed: 2014-01-21 10:00:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Postgres Logs 1 (892.42 KB, text/plain)
2013-10-09 00:56 EDT, Jaison Raju
no flags Details
ovirt-engine-dwhd log 2 (3.74 MB, text/plain)
2013-10-09 00:57 EDT, Jaison Raju
no flags Details
engine db (2.93 MB, application/x-tar)
2013-10-09 00:58 EDT, Jaison Raju
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20019 None None None Never

  None (edit)
Description Jaison Raju 2013-10-09 00:56:35 EDT
Created attachment 809648 [details]
Postgres Logs 1

Description of problem:


ovirt-engine-dwh.log:
org.postgresql.util.PSQLException: ERROR: value too long for type character varying(255)
        at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2062)
        at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1795)
        at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:479)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:367)
        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdbc2Statement.java:321)
        at ovirt_engine_dwh.aggregationtohourly_3_2.AggregationToHourly.tJDBCInput_10Process(AggregationToHourly.java:22116)
        at ovirt_engine_dwh.aggregationtohourly_3_2.AggregationToHourly$9.run(AggregationToHourly.java:23371)
org.postgresql.util.PSQLException: ERROR: current transaction is aborted, commands ignored until end of transaction block


From postgres logs :
LOG:  autovacuum: found orphan temp table "pg_temp_20"."tt_temp22" in database "engine"
LOG:  autovacuum: found orphan temp table "pg_temp_16"."tt_temp22" in database "engine"
ERROR:  value too long for type character varying(255)
STATEMENT:  INSERT INTO statistics_vms_users_usage_hourly (history_datetime,user_name,vm_id,session_time_in_minutes,cpu_usage_percent,max_cpu_usage,memory_usage_percent,max_memory_usage,user_cpu_usage_percent,max_user_cpu_usage_percent,
system_cpu_usage_percent,max_system_cpu_usage_percent,vm_ip,currently_running_on_host,vm_configuration_version,current_host_configuration_version) VALUES ($1,$2,$3,$4,$5,$6,$7,$8,$9,$10,$11,$12,$13,$14,$15,$16)
ERROR:  current transaction is aborted, commands ignored until end of transaction block
STATEMENT:  INSERT INTO storage_domain_hourly_history (history_datetime,storage_domain_id,storage_domain_status,minutes_in_status,available_disk_size_gb,used_disk_size_gb,storage_configuration_version) VALUES ($1,$2,$3,$4,$5,$6,$7)

select case when vm_ip is null then 0 else char_length(vm_ip) end as vm_ip_length, vm_guid from vm_dynamic order by vm_ip_length desc limit 5;

 vm_ip_length |               vm_guid                
--------------+--------------------------------------
          395 | 237cbc29-300f-42fe-84eb-b371b3bea984
          186 | ee9049c4-27ac-4d24-846c-c6e86e0c8d03
          128 | c2b1b403-7f76-472c-bb60-ae1d62f1851b
           47 | 6f62d48d-618d-4690-9b4e-374c9d69770f
           32 | e3ed7c05-037f-4b77-943a-f15d5d6c648d
(5 rows)

One of the VM IP is more than 255 .
I understand that 953148 bug raises the character limit , but 
not sure if this is pointing to any other issue because i have checked
most other attribute values in vm_dynamic , but couldnt find
any value above limit .

Version-Release number of selected component (if applicable):
 rhevm-dwh-3.2.1-2.el6ev.noarch

How reproducible:
No.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jaison Raju 2013-10-09 00:57:51 EDT
Created attachment 809649 [details]
ovirt-engine-dwhd log 2
Comment 2 Jaison Raju 2013-10-09 00:58:54 EDT
Created attachment 809650 [details]
engine db
Comment 3 Yaniv Lavi (Dary) 2013-10-09 05:51:55 EDT
Please add z stream flag, this is a regression.



Yaniv
Comment 7 Barak Dagan 2013-11-10 04:31:13 EST
Verified on IS21:

rhevm-dwh-3.3.0-18.el6ev.noarch
jasperreports-server-pro-5.5.0-4.el6ev.noarch
rhevm-reports-3.3.0-18.el6ev.noarch

#tail -n1 /var/log/ovirt-engine/ovirt-engine-dwhd.log 
2013-11-06 21:03:12|ETL Service Started

# date
Sun Nov 10 14:22:51 IST 2013


select vm_name, length (vm_ip) from vms order by 2 desc;'
 vm_name | length 
---------+--------
 VM-0    |    363
 VM-1    |      0
 VM-2    |      0
 VM-3    |      0
 VM-4    |      0
(5 rows)

BR10[a/b] reports working fine, no error in the log.
Comment 8 Charlie 2013-11-27 19:54:54 EST
This bug is currently attached to errata RHEA-2013:15116. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 10:00:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0036.html

Note You need to log in before you can comment on or make changes to this bug.