Bug 1017011 - Adding possibility to change type of object store to JDBC one under the Transaction subsytem
Adding possibility to change type of object store to JDBC one under the Trans...
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Harald Pehl
Jakub Cechacek
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 03:09 EDT by Ondrej Chaloupka
Modified: 2015-11-23 03:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:13:46 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-444 Minor Closed Adding possibility to change type of object store to JDBC one under the Transaction subsytem 2016-04-13 10:10 EDT

  None (edit)
Description Ondrej Chaloupka 2013-10-09 03:09:15 EDT
Web console currently contains item "Use HornetQ Store?" under tab Common.
This allows user change the object store which will be used for saving information about on-fly transactions.

The EAP 6.2.0 comes with new type of object store - JDBC object store. I suppose that adding such configuration option would be logical step.

The JDBC object store needs to be referenced to existing datasource and its settings have following limitations:
 - it has to be standard datasource (not the xa one)
 - the datasource *has to* be set as jta=false (otherwise the server even fails to start)
 - the server has to be restarted for the jdbc object store would be activated  (reload is not enough)
Comment 1 Ondrej Chaloupka 2013-10-10 10:11:51 EDT
I've got one more idea about this - when JDBC object store is set then hornetq object store has to be deactivated. Maybe there could be better to have radio buttons with file system/hornetq/jdbc object stores. But this is just an idea.
Comment 2 Heiko Braun 2014-07-02 10:07:02 EDT
Please use the community Jira for feature requests next time.
Comment 3 Heiko Braun 2014-07-02 10:13:46 EDT
The JDBC store config seems to be more complex than just a the data source name. Please create feature request in the community Jira and outline the complete use case and everything impact/constraint it might have on the hornetq store configuration option.

I am going to close this one.
Comment 4 JBoss JIRA Server 2015-11-04 05:37:30 EST
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-444 to Coding In Progress
Comment 5 JBoss JIRA Server 2015-11-23 03:59:25 EST
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-444 to Resolved
Comment 6 JBoss JIRA Server 2015-11-23 03:59:32 EST
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-444 to Reopened
Comment 7 JBoss JIRA Server 2015-11-23 03:59:38 EST
Heiko Braun <ike.braun@googlemail.com> updated the status of jira HAL-444 to Closed

Note You need to log in before you can comment on or make changes to this bug.