Bug 1017036 - [Quota]: setting a value to default-soft-limit does not work on a volume updated from Big Bend
[Quota]: setting a value to default-soft-limit does not work on a volume upd...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 04:02 EDT by Sachidananda Urs
Modified: 2016-01-19 01:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 04:16:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-10-09 04:02:09 EDT
Description of problem:
Setting a value to default-soft-limit does not work

For example:

[root@boggs ~]# gluster volume quota pure_gold list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        100.0GB       20%      77.9GB  22.1GB
[root@boggs ~]# gluster volume quota pure_gold default-soft-limit 40
volume quota : success
[root@boggs ~]# gluster volume quota pure_gold list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        100.0GB       20%   16384.0PB 101.2GB
[root@boggs ~]# gluster volume quota pure_gold default-soft-limit 40%
volume quota : success
[root@boggs ~]# gluster volume quota pure_gold list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        100.0GB       20%      77.9GB  22.1GB
[root@boggs ~]# 


Version-Release number of selected component (if applicable):
glusterfs 3.4.0.34rhs

How reproducible:
Intermittent


Expected results:
Should be able to set a different value to default-soft-limit

Additional info:

This is a pre-existing volume. i.e the volume existed in Big Bend, now the cluster is upgraded to glusterfs 3.4.0.34rhs

If I create a fresh volume and change the default-soft-limit, it works as expected. For example:

[root@boggs ~]# gluster volume quota sh list /                                                                                      
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                         40.0GB       100      29.8MB  40.0GB
[root@boggs ~]# gluster volume quota sh default-soft-limit 50
volume quota : success
[root@boggs ~]# gluster volume quota sh default-soft-limit 55%
volume quota : success
[root@boggs ~]# gluster volume quota sh list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                         40.0GB       55%      29.8MB  40.0GB
[root@boggs ~]# gluster volume quota sh default-soft-limit 60
volume quota : success
[root@boggs ~]# gluster volume quota sh list 
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                         40.0GB        60      29.8MB  40.0GB
[root@boggs ~]# 

=============================

Uploading sosreports. It is very huge. There is no definitive way to reproduce the issue. Hence keeping all the logs, not to miss anything.
Comment 2 Sachidananda Urs 2013-10-09 05:43:42 EDT
[root@boggs ~]# gluster vol info
 
Volume Name: pure_gold
Type: Distributed-Replicate
Volume ID: c5ac684b-fe8f-4e6c-ba06-53f7aac6e210
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.70.37.91:/rhs/brick1/r0
Brick2: 10.70.37.216:/rhs/brick1/r0
Brick3: 10.70.37.64:/rhs/brick1/r1
Brick4: 10.70.37.117:/rhs/brick1/r1
Options Reconfigured:
features.default-soft-limit: 40%
features.quota: on

The sosreport can be found at: http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1017036/

Note: The reset value can be found in vol info but not in quota list.
Comment 4 Vivek Agarwal 2013-10-10 04:16:36 EDT
per discussion with Saurabh, closing this as not a bug

Note You need to log in before you can comment on or make changes to this bug.