Bug 1017051 - Add DNF support
Add DNF support
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 04:17 EDT by Vít Ondruch
Modified: 2014-11-05 02:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 09:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2013-10-09 04:17:32 EDT
DNF is in Fedora since F18. Since it should become replacement for YUM in F21/F22 (not sure about the timeframe), it might be the right time to add DNF support into mock.

Thanks for considering.
Comment 1 Miroslav Suchý 2014-05-16 09:52:20 EDT
There is nothing special about yum in mock. You can remove /usr/bin/yum and make it symlink to /usr/bin/dnf and it should work (and this what will likely happen in F20).

I tried to replace:
        self.yum_path = '/usr/bin/yum'
by 
        self.yum_path = '/usr/bin/dnf'
in
  /usr/lib/python2.7/site-packages/mockbuild/backend.py
which is only occurence of yum in mock and I was able to build packages successfuly.

Generaly spoken, mock is ready. If you find some corner case, please report it separately.
Comment 2 Daniel Miranda 2014-11-04 15:42:10 EST
Right now the mock package still depends on yum-utils, and the code seems to only know about yum's cache/repo directories. It would be nice to have that updated and an optional dependency on dnf introduced.
Comment 3 Miroslav Suchý 2014-11-05 02:36:37 EST
Yum is still primary package manager. The change will not happen till F22 and/or till we will have rich dependencies in rpm.

Note You need to log in before you can comment on or make changes to this bug.