Bug 1017153 - Insufficient failure message
Insufficient failure message
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
high Severity high
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Pavol Srna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 06:51 EDT by Pavol Srna
Modified: 2014-02-06 10:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (81.84 KB, image/png)
2013-10-09 06:51 EDT, Pavol Srna
no flags Details
processing-panel (261.97 KB, image/png)
2013-10-10 05:59 EDT, Pavol Srna
no flags Details

  None (edit)
Description Pavol Srna 2013-10-09 06:51:55 EDT
Created attachment 809844 [details]
screenshot

Description of problem:

I often end up in situations, when I have no idea what has gone wrong in the installation. There is just a "Installation has failed." message on the last page. Nothing more. This is very insufficient, because user doesn't know if just a sub-module installation has failed, or the whole installation is corrupt, or what is going on...

Let's have this example scenario:

Accept all installer defaults and decide to install LDAP authentication.
On the ldap configuration panel type in wrong DN password. Fill in all other necessary fields and continue with the installation. On the very last page you will see a message "Installation has failed" with no obvious reason. There was even no error message on the 'processing' panel. And that is wrong.
Comment 1 Thomas Hauser 2013-10-09 09:55:56 EDT
Hello Pavol,

I agree that there is a general lack of information regarding failures in the installer. This is something that is being discussed.

However, for this particular issue, I am unable to reproduce using the procedure you describe in the example scenario. Which OS are you using?

Thanks,
Tom
Comment 2 Pavol Srna 2013-10-09 10:11:05 EDT
I used ubuntu 12.04 LTS x86, and oracle java 1.7.0_40 and I tried against a local running LDAP server.
Comment 3 Pavol Srna 2013-10-10 05:59:30 EDT
Another good example of weak error logging is when you try to configure mysql and mysql server answers with for example: 'ERROR 2003 (HY000): Can't connect to MySQL server on ...' You will hardly notice the error because when you realize that something went wrong you are on the last page saying "Installation has failed." and all other logs are almost empty.

See my screenshot from the processing panel. You can see that dtgov-sram-repo-seed-cli-command has failed with exit code 1. My point here is, that in so much text it is almost impossible to realize that there went something wrong. And also the Next button was enabled!
Comment 4 Pavol Srna 2013-10-10 05:59:57 EDT
Created attachment 810423 [details]
processing-panel
Comment 6 Thomas Hauser 2013-11-13 12:35:10 EST
The installer now produces a log that will contain much more detailed information.
Comment 7 Pavol Srna 2013-12-12 08:42:56 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.