Bug 1017185 - dwarf_getfuncs makes systemtap miss some function probes in c++ programs and with dwz compressed DWARF
dwarf_getfuncs makes systemtap miss some function probes in c++ programs and ...
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: elfutils (Show other bugs)
DTS 2.1 RHEL 6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.4
Assigned To: Petr Machata
Dagmar Prokopová
: Rebase
Depends On: 1011579
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 07:57 EDT by Mark Wielaard
Modified: 2015-05-04 21:38 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list. Rebase package(s) to version: 0.157 Highlights, important fixes, or notable enhancements: For this bug in particular: Cause: dwarf_getfuncs should return all functions defined by a given compilation unit. But when considering candidate nodes, it only scanned the first layer of nodes attached to a given compilation unit, even though such function definition nodes could be nested in deeper layers of the Dwarf tree. GCC emits Dwarf nodes representing nested functions under the nodes that represent the outer function. Consequence: dwarf_getfuncs wouldn't report nested functions for GCC-generated Dwarf data. Fix: The whole Dwarf tree rooted at a given compilation unit is scanned. Result: All function definitions are found.
Story Points: ---
Clone Of: 1011579
Environment:
Last Closed: 2014-03-11 02:38:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Dagmar Prokopová 2013-11-11 09:29:15 EST
Verified for devtoolset-2-elfutils-0.157-1. (Patch in place and new test in the testsuite passed.)
Comment 5 errata-xmlrpc 2014-03-11 02:38:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0271.html

Note You need to log in before you can comment on or make changes to this bug.