Bug 1017272 - introspection.m4 file sometimes not included in widgets/src/Makefile.am
introspection.m4 file sometimes not included in widgets/src/Makefile.am
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 10:30 EDT by mulhern
Modified: 2014-01-30 17:09 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-20.25-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:09:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mulhern 2013-10-09 10:30:53 EDT
Description of problem:

automake error: src/Makefile.am:77: error: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL

Version-Release number of selected component (if applicable):

master as of: Tue Oct 8 16:10:58 2013 +0200

How reproducible:

If introspection.m4 not found. Apparently it is not included in gobject-introspection package, but rather in gobject-introspection-devel package.

Steps to Reproduce:
1. ./autogen.sh at command line

Actual results:

automake error shown above

Expected results:

No errors

Additional info:

widgets/src/Makefile.am -includes $(INTROSPECTION_MAKEFILE) which should be widgets/m4/introspection.m4. This file was included in commit add0aeee but removed again in commit 38a1a9e3 because libtoolize is expected to provide it. It was not provided on my machine, but was once I installed gobject-introspection-devel.

Suggested fix: widgets/configure.ac check for appropriate version of gobject-introspection-devel, not gobject-introspection.
Comment 1 mulhern 2013-10-09 10:51:42 EDT
Probably including both is best.
Comment 2 David Shea 2013-10-09 11:28:30 EDT
Added a check for whether the GOBJECT_INTROSPECTION_CHECK macro expanded during the autoconf phase, so now the error looks like:

configure.ac:43: error: possibly undefined macro: GOBJECT_INTROSPECTION_CHECK
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

which is hopefully less cryptic.

Note You need to log in before you can comment on or make changes to this bug.