Bug 1017293 - mod_cluster: Table 16.4. mod_cluster Configuration Options: Balancer
mod_cluster: Table 16.4. mod_cluster Configuration Options: Balancer
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER3
: EAP 6.4.0
Assigned To: Russell Dickenson
Michal Karm Babacek
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 11:10 EDT by Michal Karm Babacek
Modified: 2015-04-17 01:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14874, Administration and Configuration Guide-6.2-1 Build Date: 02-10-2013 13:01:57 Topic ID: 8982-459087 [Latest]
Last Closed: 2015-04-17 01:56:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Karm Babacek 2013-10-09 11:10:40 EDT
Table 16.4. mod_cluster Configuration Options
Balancer
The name of the balancer. This should match the configuration of the HTTPD proxy.
BUGS: Hmm, bogus description.

Hi guys, this description is actually somewhat divorced from reality,
in my own words, I would rephrase it as something like:

Balancer attribute actually means what mod_proxy balancer should be automatically configured by mod_cluster on Apache HTTP Server.

The default is none, JBoss EAP6 instance does not tell any spcific balancer name by default, the default used is "mycluster" (balancer://mycluster/ expressed in mod_proxy terms). This default value is configured on Apache HTTP Server side with ManagerBalancerName directive. 

E.g. if one uses two different balancer attribute values on ones JBoss EAP 6 worker instances, there will be two different mod_proxy balancers created by mod_cluster automatically on Apache HTTP Server side.

HTH

-M-
Comment 1 Michal Karm Babacek 2014-11-06 08:42:39 EST
Dear Doc guys, could you look into it please?
Comment 2 Michal Karm Babacek 2015-01-20 08:50:17 EST
Hi Tom, I would like to ask you to update the status of this bugzilla.
Could you take a look at it, please? I don't know how to find out who's been working on it.

Thanks
Comment 4 Nikoleta Ziakova 2015-02-09 03:00:00 EST
The books have not been built since the changes for this BZ were made. Please move the BZ to ON_QA state once it is ready for verification.

Note You need to log in before you can comment on or make changes to this bug.