This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 101734 - kernel-smp-2.6.0-0.test kernels + ip_conntrack = slow xmit?
kernel-smp-2.6.0-0.test kernels + ip_conntrack = slow xmit?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-06 09:20 EDT by Thomas J. Baker
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 03:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2003-08-06 09:20:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.8.2

Description of problem:
Is it a known problem that on my e1000 interface, if iptables type
modules are insmodded, my outgoing traffic slows to a crawl?

Modules in question:

ip_nat_irc              5360  0
ip_nat_ftp              6000  0
iptable_nat            24996  4 ipt_MASQUERADE,ip_nat_irc,ip_nat_ftp
ip_conntrack_irc       72340  1 ip_nat_irc
ip_conntrack_ftp       73236  1 ip_nat_ftp
ip_conntrack           31788  6
ipt_MASQUERADE,ip_nat_irc,ip_nat_ftp,iptable_nat,ip_conntrack_irc,ip_conntrack_ftp
ip_tables              19712  2 ipt_MASQUERADE,iptable_nat

Without them, I get normal 100Mbs type transfers approaching 10MB/s but with
them installed, I'm getting closer to 50KB/s. If I remove the
modules, things work as expected. (I need though them so my ipaq can talk to the
rest of the world.) Or is this just an old software/new kernel problem?

I'm running 2.6.0-0.test2.1.29smp on a dual 3.0GHz Dell 650N.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.0-0.test2.1.29

How reproducible:
Always

Steps to Reproduce:
1. run 2.6 test kernel
2. install iptables modules
3. transfer any file to another system
    

Actual Results:  Transfer speeds are generally below 50KB/s.

Expected Results:  Transfer speeds are in the normal 8-11MB/s.

Additional info:

I'm just trying to figure out of this is a software (iptables) issue or a kernel
issue. I can provide any other details that are needed.
Comment 1 James Morris 2003-08-06 11:15:20 EDT
Can you try loading each module separately and find out which one causes the
slowdown?

Also, do you have any iptables rules installed?
Comment 2 Thomas J. Baker 2003-08-06 16:04:38 EDT
ip_conntrack is what does it:

[tjb@wintermute incoming]# modprobe ip_conntrack
[tjb@wintermute incoming]# time scp radiohead.mov katratzi:/tmp
root@katratzi's password:
radiohead.mov                                   1%  836KB  49.1KB/s   19:50
ETAKilled by signal 2.
0.000u 0.007s 0:22.98 0.0%      0+0k 0+0io 224pf+0w
[tjb@wintermute incoming]# rmmod ip_conntrack
[tjb@wintermute incoming]# time scp radiohead.mov katratzi:/tmp
root@katratzi's password:
radiohead.mov                                 100%   57MB   8.3MB/s   00:06
1.408u 0.297s 0:12.08 13.9%     0+0k 0+0io 623pf+0w
[tjb@wintermute incoming]#
Comment 3 Thomas J. Baker 2003-08-21 15:01:32 EDT
This also happens with 2.6.0-0.test3.1.31smp.
Comment 4 Thomas J. Baker 2003-08-26 09:48:14 EDT
2.6.0-0.test4.1.32smp too.
Comment 5 Thomas J. Baker 2003-09-26 08:25:12 EDT
I just tried this on 2.6.0-0.test5.1.45smp and the problem is still there to
some degree. When transfering a 93MB file, the first 2.5MB or so is transfered
at about 50KB/s and then suddenly the transfer speed increases to about 8MB/s.
The total transfer time for a 93MB file averages about 1 minute with the
ip_conntrack installed and 11 seconds after removing it.
Comment 6 David Miller 2003-09-26 08:48:53 EDT
If it happens with 2.6.x, please report this
to the netfilter list (netfilter@lists.netfilter.org).  They play
with this stuff every day, so they're likely to figure out what the
problem is several orders of magnitude faster than I could.
Comment 7 Thomas J. Baker 2004-05-11 21:48:18 EDT
Fixed in recent kernels including kernel-smp-2.6.5-1.358.

Note You need to log in before you can comment on or make changes to this bug.