Bug 1017387 - Upgrade to 3.2 fails if there is no agent to upgrade
Upgrade to 3.2 fails if there is no agent to upgrade
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Upgrade (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER04
: JON 3.2.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 14:49 EDT by Jay Shaughnessy
Modified: 2014-01-02 15:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2013-10-09 14:49:04 EDT
Upgrading to 3.2 fails if the user is upgrading only a server.  Typically there is a legacy agent involved in the upgrade; specified with --from-agent-dir or already in the default location.  But it is not required, users electing not to monitor their JON server may not have installed an agent local to their server.

Actual:
Failure reported and the storage and serve upgrades are reverted.

Expected:
An new agent should be installed if no agent is specified or found.
Comment 1 Jay Shaughnessy 2013-10-09 14:55:08 EDT
The following commits fix the issue.

commit 8f17c431d083a9e1c74db3038cec768b1ca2dfb6
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Wed Oct 9 13:10:04 2013 -0400

    Fix merge issue

commit 92651ca1b4793058343e020fbc305fc125efe23e
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Wed Oct 9 10:32:14 2013 -0400

    Upgrading to rhq410/jon32 would fail, and revert, if there were no agent
    to upgrade.  For a server only installation the user would not
    specify --from-agent-dir and also there was no rhq-agent dir at the sibling
    position to the server install dir.  This would cause the failure with
    the upgrade complaining there was no agent to upgrade.

    Now a new agent will be installed in this situation, as part of the upgrade.



If backporting we may also want due to the same code being modified:

commit 79402bca21950384646860ae1493d250cda076c3
Author: John Mazzitelli <mazz@redhat.com>
Date:   Tue Oct 8 17:15:18 2013 -0400

    BZ 1016885 - log messages when undo tasks are triggered
Comment 2 Simeon Pinder 2013-10-11 10:55:55 EDT
Hi Jay, this is OK'd for ER4. Please cherry-pick this to release/jon3.2.x for ER4.

Moving back to ASSIGNED, since the fix is not actually in the release branch yet.
Comment 3 Jay Shaughnessy 2013-10-11 23:14:39 EDT
release/jon3.2.x commit a11fb30850a0b0a5209d323c8bcf1c7805a3079e

  cherry pick of 79402bca21950384646860ae1493d250cda076c3


release/jon3.2.x commit 090c3c230186d751b510ba6d37f21acc869ef689

  cherry pick of 92651ca1b4793058343e020fbc305fc125efe23e


release/jon3.2.x commit 2c2b97dd5478a7a8704bd89480fb5f9382e083eb

  cherry pick of 8f17c431d083a9e1c74db3038cec768b1ca2dfb6
Comment 4 Simeon Pinder 2013-10-24 00:10:32 EDT
Moving to ON_QA for testing in the next build.
Comment 5 Filip Brychta 2013-10-31 12:22:40 EDT
Verified on
Version: 3.2.0.ER4
Build Number: e413566:057b211

Note You need to log in before you can comment on or make changes to this bug.