Bug 101741 - netconfig does not change /etc/hosts, leaves GATEWAY entry
netconfig does not change /etc/hosts, leaves GATEWAY entry
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: pump (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-06 10:19 EDT by Jan Iven
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 18:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Iven 2003-08-06 10:19:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030708

Description of problem:
Modifying the IP address via 

netconfig --ip=... -gateway=..

(or interactively) only changes /etc/sysconfig/network-scripts/ifcfg-eth0, but
does not enter the new IP address/host pair into /etc/hosts.

It also does not update/remove a "GATEWAY=" entry in /etc/sysconfig/network
(where it apparently gets placed by default), instead simply adds GATEWAY=xxx
into /etc/sysconfig/network-scripts/ifcfg-eth0.



Version-Release number of selected component (if applicable):
netconfig-0.8.15-3 (similarly on RH7)

How reproducible:
Always

Steps to Reproduce:
1.netconfig --ip=1.2.3.4 --gateway=1.2.1.1
2.cat /etc/hosts

    

Actual Results:  # Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1		localhost.localdomain localhost
137.138.30.11		asis-w2.cern.ch asis-w2


Expected Results:  # Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1		localhost.localdomain localhost
1.2.3.4	      whatever DNS says about 1.2.3.4


Additional info:

netconfig appears still to be the tool to use for this, despite
redhat-config-network (which apparently has no "batch/command-line" mode). Since
it looks like the tool is doing a proper job (no error messages, network
connectivity comes back  up after network restart), this error may be difficult
to spot for admins.
Comment 1 Eido Inoue 2003-08-07 18:44:10 EDT
redhat-config-network is now the preferred tool for configuring the network.
netconfig, can (for past releases for use by the installer/kickstart) be used as
a command-line tool, but it's not intended to be used this way.

netconfig should be considered to be deprecated and only for compatibility.

Note You need to log in before you can comment on or make changes to this bug.