Bug 1017412 - Installer does not let user pick components in terminal mode
Installer does not let user pick components in terminal mode
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 16:12 EDT by Rick Wagner
Modified: 2013-10-25 09:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 13:50:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Wagner 2013-10-09 16:12:54 EDT
When using a terminal on a machine the user is ssh'ed into, we get this choice:

Select the packs you want to install:
1    [x] [Required]      [Red Hat JBoss Enterprise Application Platform]
2    [x]                 [Red Hat JBoss Fuse Service Works]
3    [ ]                 [RT-Gov Client-only]
4    [x]                 [RT-Gov Server+Client]
5    [x]                 [DT-Gov run-time]
6    [x]                 [S-RAMP run-time]
7    [x]                 [Red Hat JBoss Fuse Service Works quickstarts]
8    [x]                 [RTGov Server quickstarts]
9    [x]                 [DTGov quickstarts]
10   [x]                 [S-RAMP quickstarts]
Press 0 to confirm your selections
Please select which packs you want to install
1
Invalid options


But the user does not seem able to make any choice other than 0, which is only a confirmation of what the installer has suggested.  Note in this example I picked '1' and got back 'Invalid options'.
Comment 1 Thomas Hauser 2013-10-09 16:43:31 EDT
Hi Rick,

You should be able to make choices other than '1', since '1' is marked required, it cannot be unchosen (we decide if the user should have a new EAP laid down or not based upon the chosen install path contents.)

If you cannot, this is indeed a bug.

Thanks,
Tom
Comment 2 Thomas Hauser 2013-10-21 13:50:57 EDT
Closing as a bug unless Rick posts evidence of being unable to make valid selections.

Note You need to log in before you can comment on or make changes to this bug.