Bug 101746 - Kudzu freezes if hardware has been removed
Summary: Kudzu freezes if hardware has been removed
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kudzu (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-06 15:11 UTC by Jean Francois Martinez
Modified: 2014-03-17 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-24 20:31:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jean Francois Martinez 2003-08-06 15:11:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
While helping with a kernel bug I had to boot with the "nousb" parm.  This
disabled my USB mouse.  When boot reached hardware detection it froze.

It happens if I boot at  runlevel 5 and also at level 3.

The box didn't react to ctral-alt-del (in the level 3 boot).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install on a box who has an USB mouse
2. Boot with "nousb" in the command line thus letting the mouse out
3.
    

Actual Results:  Box froze.

Additional info:

Comment 1 Bill Nottingham 2003-08-06 16:15:39 UTC
Is the reason you're booting with nousb is because USB blows up the kernel?

Comment 2 Jean Francois Martinez 2003-08-06 18:42:15 UTC
Loading USB modules when ACPI is enabled freezes the kernel.  The person who is
iinvestigating the problem wanted dmesg ouput for a boot without ACPI and for 
one with ACPI.  The later requires disabling USB, that is how I stumbled upon
the kudzu problem.

See bug 101519 for details. 

Comment 3 Jean Francois Martinez 2003-08-24 20:31:00 UTC
I discovered that this is not a kudzu problem but a kernel problem: with
full ACPI (ie without pci=noacpi) the kernel freezes when I start Kudzu
from the command line (ie I cannot switch consoles, browse upwards and 
CTRL-ALT-DEL does not work)


Note You need to log in before you can comment on or make changes to this bug.