Bug 101749 - draft items do not have last modified or creation dates
Summary: draft items do not have last modified or creation dates
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 110952
TreeView+ depends on / blocked
 
Reported: 2003-08-06 15:27 UTC by Crag Wolfe
Modified: 2007-04-18 16:56 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-10-13 20:09:24 UTC


Attachments (Terms of Use)

Description Crag Wolfe 2003-08-06 15:27:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
In my case, I'm only concerned with draft items for UNDP's content-item backed
document manager.  Currenlty, it looks like creation/modified dates only get set
for published items.

Version-Release number of selected component (if applicable):
latest troika

How reproducible:
Always

Steps to Reproduce:
Need to code to reproduce I think, just call item.getLastModifiedDate() and
item.getCreationDate().

Additional info:

Comment 1 Mike Bonnet 2003-12-11 21:42:26 UTC
It looks like the root of the problem is that
Versions.getAuditInfo(OID) calls getCreationTxn(), which calls
getTaggedTxns().  Unfortunately, almost no transactions are tagged. 
Only transactions having to do with completing Workflow tasks and
publishing are tagged.  It appears that almost every use of
getTaggedTxns() in Versions (in getMostRecentTxnID(),
getCreationTxn(), and getLastTxn()) should be replaced with getTxns().

Comment 2 Jon Orris 2003-12-12 22:17:19 UTC
Putting on Troika 6.0.1 blocker list
Merge 38778 

Comment 3 Archit Shah 2003-12-15 16:21:12 UTC
merged to troika (38810)


Note You need to log in before you can comment on or make changes to this bug.