Bug 1017526 - virt-who is not built automatically in the RHEVH
virt-who is not built automatically in the RHEVH
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 02:04 EDT by Liushihui
Modified: 2014-01-21 14:53 EST (History)
18 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Enhancement
Doc Text:
The virt-who package, which provides an agent for reporting virtual guest IDs to subscription-manager, is now installed by default with the rhn-plugin for the hypervisor.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:53:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
profile (46 bytes, text/plain)
2013-10-10 02:04 EDT, Liushihui
no flags Details
distro (634 bytes, text/plain)
2013-10-10 02:05 EDT, Liushihui
no flags Details

  None (edit)
Description Liushihui 2013-10-10 02:04:23 EDT
Created attachment 810298 [details]
profile

Description of problem:
Installed RHEVH successfully, But the vdsm and virt-who hasn't been installed, it will result in the RHEVH host can't be added to RHEVM automatically.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso 
ovirt-node-3.0.1-3.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1.Start to install RHEVH, Choose the kickstart file from the PXE, name:rhevh-6.5-20130930.0.el6ev , please see this kickstart file's profile and distro in the attachment.
2. Following the instruction to install RHEVH
3. After auto install success, then login rhev-h , Check the status of virt-who and vdsmd.
   # rpm -q virt-who
   package virt-who is not installed
   # rpm -q vdsm
   package vdsm is not installed


Actual results:
The virt-who and vdsmd haven't been installed automatically in the RHEVH

Expected results:
The virt-who and vdsmd should be install automatically in the RHEVH

Additional info:
Comment 1 Liushihui 2013-10-10 02:05:26 EDT
Created attachment 810299 [details]
distro
Comment 6 Ying Cui 2013-10-12 05:43:43 EDT
Tested this bug with builds rhev-hypervisor6-6.5-20130930.0.auto665(RHEV-H Base image) and rhev-hypervisor6-6.5-20131011.0.el6ev(RHEV build), there is no virt-who package, so qa_ack+ this bug.
Comment 9 RHEL Product and Program Management 2013-10-16 22:45:14 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 14 Ying Cui 2013-10-28 06:28:03 EDT
Tested in rhevh-6.5-20131024.1.0
          ovirt-node-3.0.1-6.el6.noarch

# rpm -qa|grep virt-who
virt-who-0.8-9.el6.noarch

virt-who has been installed by default in RHEV-H 6.5 base image build.
Comment 16 errata-xmlrpc 2014-01-21 14:53:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.