Bug 1017529 - [virtio-win][virtio-scsi] BSOD occurs when do I/O test on virtio scsi driver
[virtio-win][virtio-scsi] BSOD occurs when do I/O test on virtio scsi driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 02:23 EDT by Xiaomei Gao
Modified: 2014-10-14 04:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-73
Doc Type: Bug Fix
Doc Text:
no docs needed (regression)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot-bsod-0xFC (21.94 KB, image/png)
2013-10-10 02:39 EDT, Xiaomei Gao
no flags Details
windbg-analyze-0xFC (5.13 KB, text/plain)
2013-10-10 02:41 EDT, Xiaomei Gao
no flags Details
screenshot-bsod-0xD1 (21.40 KB, image/png)
2013-10-10 02:42 EDT, Xiaomei Gao
no flags Details
windbg-analyze-0xD1 (3.63 KB, text/plain)
2013-10-10 02:43 EDT, Xiaomei Gao
no flags Details

  None (edit)
Description Xiaomei Gao 2013-10-10 02:23:33 EDT
Description of problem:
Windows guest will get BSOD when do I/O test on virtio-scsi driver. I test the issue for 2 times and get different BSOS code: 0xFC, OxD1

Version-Release number of selected component (if applicable):
- Host version:
  qemu-kvm-0.12.1.2-2.405.el6.x86_64
  kernel-2.6.32-420.el6.x86_64

- Guest version: Win2008r2.x86_64
  virtio-win-prewhql-0.1-72

How reproducible:
2/2

Steps to Reproduce:
1. Boot windows guest with SSD data disk
   /usr/libexec/qemu-kvm  \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=hmp_id_humanmonitor1,path=/tmp/monitor-humanmonitor1-20131010-010618-R5iCJoNK,server,nowait \
    -mon chardev=hmp_id_humanmonitor1,mode=readline \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20131010-010618-R5iCJoNK,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20131010-010618-R5iCJoNK,path=/tmp/seabios-20131010-010618-R5iCJoNK,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20131010-010618-R5iCJoNK,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x3 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x4 \
    -drive file='/usr/local/autotest/tests/virt/shared/data/images/win2008r2-64.raw',if=none,id=virtio-scsi0-id0,media=disk,cache=none,snapshot=off,format=raw,aio=native \
    -device scsi-hd,drive=virtio-scsi0-id0 \
    -drive file='/dev/sdb',if=none,id=virtio-scsi2-id1,media=disk,cache=none,snapshot=off,format=raw,aio=native \
    -device scsi-hd,drive=virtio-scsi2-id1 \
    -device rtl8139,netdev=id0dXCZt,mac='9a:37:37:37:37:8e',bus=pci.0,addr=0x5,id='idBMtorL' \
    -netdev tap,id=id0dXCZt \
    -m 4096 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Westmere' \
    -M rhel6.5.0 \
    -drive file='/usr/local/autotest/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=virtio-scsi1-id2,media=cdrom,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi1-id2 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga cirrus \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off   \
    -device sga \
    -enable-kvm

2. Do fio test on data disk
   C:\fio-2.0.15-x64\fio.exe --rw=read --bs=4k --iodepth=8 --runtime=1m --direct=1 --filename=\\.\PHYSICALDRIVE1 --name=job1 --ioengine=windowsaio --thread --group_reporting --numjobs=16 --size=512MB --time_based --output="C:\\fio_result"

Actual results:
Guest hit BSOD after doing above step 2.

Expected results:
Guest works well.

Additional info:
IDE/VIRTIO_BLK driver works well and i will attach the dump file later.
Comment 2 Xiaomei Gao 2013-10-10 02:39:02 EDT
Created attachment 810320 [details]
screenshot-bsod-0xFC
Comment 3 Xiaomei Gao 2013-10-10 02:41:29 EDT
Created attachment 810321 [details]
windbg-analyze-0xFC
Comment 4 Xiaomei Gao 2013-10-10 02:42:41 EDT
Created attachment 810322 [details]
screenshot-bsod-0xD1
Comment 5 Xiaomei Gao 2013-10-10 02:43:50 EDT
Created attachment 810324 [details]
windbg-analyze-0xD1
Comment 6 Vadim Rozenfeld 2013-10-10 06:51:56 EDT
Thanks,
Since we are hitting a very similar issue, which happens on 64-bit platforms 
only, could you please check if this problem can be reproduced on 32-bit platforms as well?

Best regards,
Vadim.
Comment 7 Vadim Rozenfeld 2013-10-10 06:55:46 EDT
could you please upload all relevant crash dump files?
Thanks,
Vadim.
Comment 11 Mike Cao 2013-10-14 03:22:42 EDT
xigao ,Could you try with scsi virtio-win-1.6.5-5.el6_4.noarch to see whether it is a regression ?

Thanks
Comment 12 Xiaomei Gao 2013-10-14 06:13:10 EDT
(In reply to Mike Cao from comment #11)
> xigao ,Could you try with scsi virtio-win-1.6.5-5.el6_4.noarch to see
> whether it is a regression ?

Hi, Mike

    Run fio test for almost one hour on Win2008r2.x86_64 virtio-scsi driver of virtio-win-1.6.6-1.el6 and Guest works well, so it is a regression bug.

Best Regards
Xiaomei
Comment 13 Vadim Rozenfeld 2013-10-14 06:24:34 EDT
(In reply to Xiaomei Gao from comment #12)
> (In reply to Mike Cao from comment #11)
> > xigao ,Could you try with scsi virtio-win-1.6.5-5.el6_4.noarch to see
> > whether it is a regression ?
> 
> Hi, Mike
> 
>     Run fio test for almost one hour on Win2008r2.x86_64 virtio-scsi driver
> of virtio-win-1.6.6-1.el6 and Guest works well, so it is a regression bug.
> 
> Best Regards
> Xiaomei

Yes, this one should be a regression, introduced during fixing bz#1003158

Thanks,
Vadim.
Comment 14 Mike Cao 2013-10-14 06:42:59 EDT
(In reply to Vadim Rozenfeld from comment #13)
> (In reply to Xiaomei Gao from comment #12)
> > (In reply to Mike Cao from comment #11)
> > > xigao ,Could you try with scsi virtio-win-1.6.5-5.el6_4.noarch to see
> > > whether it is a regression ?
> > 
> > Hi, Mike
> > 
> >     Run fio test for almost one hour on Win2008r2.x86_64 virtio-scsi driver
> > of virtio-win-1.6.6-1.el6 and Guest works well, so it is a regression bug.
> > 
> > Best Regards
> > Xiaomei
> 
> Yes, this one should be a regression, introduced during fixing bz#1003158
> 
> Thanks,
> Vadim.

Can we revert the patch as Bug #1003158 failed QA as well .

Thanks, 
Mike
Comment 15 Vadim Rozenfeld 2013-10-14 10:42:25 EDT
(In reply to Mike Cao from comment #14)
> (In reply to Vadim Rozenfeld from comment #13)
> > (In reply to Xiaomei Gao from comment #12)
> > > (In reply to Mike Cao from comment #11)
> > > > xigao ,Could you try with scsi virtio-win-1.6.5-5.el6_4.noarch to see
> > > > whether it is a regression ?
> > > 
> > > Hi, Mike
> > > 
> > >     Run fio test for almost one hour on Win2008r2.x86_64 virtio-scsi driver
> > > of virtio-win-1.6.6-1.el6 and Guest works well, so it is a regression bug.
> > > 
> > > Best Regards
> > > Xiaomei
> > 
> > Yes, this one should be a regression, introduced during fixing bz#1003158
> > 
> > Thanks,
> > Vadim.
> 
> Can we revert the patch as Bug #1003158 failed QA as well .
Hi Mike,
I would rather prefer to fix it as soon as possible.
Best regards,
Vadim.

> 
> Thanks, 
> Mike
Comment 16 lijin 2013-10-15 06:02:10 EDT
QE can reproduce this issue only with system disk and data disk on the same virtio-scsi-pci controller.
If system disk and data disk are on different virtio-scsi-pci and do fio/iometer test on data disk,guest works fine,no bsod.
Comment 17 lijin 2013-10-15 06:08:10 EDT
(In reply to lijin from comment #16)
> QE can reproduce this issue only with system disk and data disk on the same
> virtio-scsi-pci controller.
> If system disk and data disk are on different virtio-scsi-pci and do
> fio/iometer test on data disk,guest works fine,no bsod.

the package info :
qemu-kvm-rhev-0.12.1.2-2.405.el6.x86_64
kernel-2.6.32-420.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64
virtio-win-prewhql-72
Comment 18 lijin 2013-11-08 04:29:45 EST
Reproduced this issue on virtio-win-prewhql-72
Verified this issue on virtio-win-prewhql-73

package info :
qemu-kvm-rhev-0.12.1.2-2.405.el6.x86_64
kernel-2.6.32-420.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64

steps same as comment #0

Actual Results:
on virtio-win-prewhql-72,guest BSOD when run fio test on data disk.
on virtio-win-prewhql-73,guest work fine with fio running and no BSOD.

Based on above ,this issue has been fixed already.
Comment 19 errata-xmlrpc 2014-10-14 04:20:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1592.html

Note You need to log in before you can comment on or make changes to this bug.