Bug 1017531 - RFE: Improve the usability of Stats display Words/Msg toggle
RFE: Improve the usability of Stats display Words/Msg toggle
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michelle Kim
Zanata-QA Mailling List
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 02:30 EDT by David Mason
Modified: 2015-07-28 23:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 23:35:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-10-10 02:30:52 EDT
Description of problem:
In translation editor, a stats display is shown near the top right of the page with a coloured bar, a percentage, estimated translation time, and the word "Words" or "Msg". Clicking "Words" or "Msg" toggles between the two.

This is confusing because it looks like the label for the stats bar is something like "99% (1.4hrs) Words", which is meaningless as an English sentence. Also, the word "Words" has the same appearance as the other text, so there is no clue that it can be clicked to toggle anything.

This should be removed or changed so that it is not confusing.


Version-Release number of selected component (if applicable):
3.0.3
Comment 1 David Mason 2013-10-10 20:57:27 EDT
On further investigation, my recommendations are:

 - make "Words" and "Msg" look clickable using colour or some other style
 - change the text so it is "X% of Words (Y hrs)" or "X% of Messages (Y hrs)"
 - add a tooltip to "Words" and "Msg" indicating what happens when it is clicked. e.g.

     Showing percentage of words translated.
     Click to change to percentage of messages translated.
Comment 2 Sean Flanigan 2013-10-10 22:28:26 EDT
(In reply to David Mason from comment #1)
>  - make "Words" and "Msg" look clickable using colour or some other style

Yes.

>  - change the text so it is "X% of Words (Y hrs)" or "X% of Messages (Y hrs)"

That's better, but the parens imply that the Y hrs is based on the Messages.  I think they should be separated more.

>  - add a tooltip to "Words" and "Msg" indicating what happens when it is
> clicked. e.g.
>     Showing percentage of words translated.
>     Click to change to percentage of messages translated.

If it's obvious that Words and Msg are clickable, I don't think the tooltips will add anything.

Come to think of it, if we use Words (plural), we should use Msgs, not Msg.
Comment 3 David Mason 2013-10-10 22:50:59 EDT
(In reply to Sean Flanigan from comment #2)
> (In reply to David Mason from comment #1)
> >  - make "Words" and "Msg" look clickable using colour or some other style
> 
> Yes.
> 
> >  - change the text so it is "X% of Words (Y hrs)" or "X% of Messages (Y hrs)"
> 
> That's better, but the parens imply that the Y hrs is based on the Messages.
> I think they should be separated more.

Agreed. We could put something like a clock icon before the remaining hours, and remove the parens:

    [||||    ] 90% of Words    (λ) 1.5 hrs

Where (λ) is a clock icon with a tooltip like "Remaining translation time"


> >  - add a tooltip to "Words" and "Msg" indicating what happens when it is
> > clicked. e.g.
> >     Showing percentage of words translated.
> >     Click to change to percentage of messages translated.
> 
> If it's obvious that Words and Msg are clickable, I don't think the tooltips
> will add anything.

My thinking is that if it looks like a link, users may be afraid to click it and be navigated away from the page they're viewing - a tooltip would provide reassurance that clicking is a safe operation that won't lose their place.

We could also just go for a presentation would not be easily confused with navigation, e.g. make the whole "X% of Words" unroll on mouseover (or touch) to show both percentages:

   X% of Words
   Y% of Messages

and make clicking change which is visible by default.

> Come to think of it, if we use Words (plural), we should use Msgs, not Msg.

Unless we have a severe economy of space, we should consider using the real word "Messages".
Comment 4 David Mason 2013-10-10 22:52:46 EDT
(In reply to David Mason from comment #3)

> We could also just go for a presentation would not be ...

*that would not
Comment 5 David Mason 2015-03-25 23:36:41 EDT
This should be a fairly straightforward change that will be a significant improvement to the affected part of the UI, so we should consider getting it done soon.
Comment 6 Zanata Migrator 2015-07-28 23:35:21 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-335

Note You need to log in before you can comment on or make changes to this bug.