Bug 101755 - ash does not build
Summary: ash does not build
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ash   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-06 15:41 UTC by Michael Redinger
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-07 01:37:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to build ash using GNU make. Needs updated spec file. (4.57 KB, patch)
2003-08-06 19:47 UTC, Lon Hohberger
no flags Details | Diff
Patch to make ash build using GNU tools. Needs new spec file. (6.57 KB, patch)
2003-08-06 20:04 UTC, Lon Hohberger
no flags Details | Diff
Updated spec file to make ash build using GNU tools. (5.81 KB, text/plain)
2003-08-06 20:05 UTC, Lon Hohberger
no flags Details

Description Michael Redinger 2003-08-06 15:41:26 UTC
The Taroon ash-0.3.8-10.src.rpm package does not build correctly
on Taroon (everything install) because there are failed dependencies:

error: Failed build dependencies:
        pmake >= 1.45 is needed by ash-0.3.8-10

pmake: not available, but included in Severn

Comment 1 Lon Hohberger 2003-08-06 19:46:12 UTC
Ported ash to GNU tools.

Comment 2 Lon Hohberger 2003-08-06 19:47:06 UTC
Created attachment 93454 [details]
Patch to build ash using GNU make.  Needs updated spec file.

Comment 3 Lon Hohberger 2003-08-06 19:48:34 UTC
Build failed on some platforms, still working kinks out.

Comment 4 Lon Hohberger 2003-08-06 20:04:02 UTC
Created attachment 93455 [details]
Patch to make ash build using GNU tools.  Needs new spec file.

Comment 5 Lon Hohberger 2003-08-06 20:05:03 UTC
Created attachment 93456 [details]
Updated spec file to make ash build using GNU tools.

Comment 6 Lon Hohberger 2003-08-06 20:13:32 UTC
ash-0.3.8-14 will be in Sushi soon.

You can try a source rpm in the meantime (which should solve the problem):

http://people.redhat.com/lhh/ash-0.3.8-14.src.rpm



Comment 7 Jay Turner 2003-08-07 01:37:11 UTC
Fix confirmed with ash-0.3.8-14.src.rpm.


Note You need to log in before you can comment on or make changes to this bug.