Bug 1017578 - Simulation engine starts less instances than is set if the process contains a parallel gateway
Simulation engine starts less instances than is set if the process contains a...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Maciej Swiderski
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 04:10 EDT by Sona Mala
Modified: 2014-08-06 16:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video file - step to reproduce (6.05 MB, video/webm)
2013-10-10 04:10 EDT, Sona Mala
no flags Details
Process image (22.90 KB, image/png)
2013-10-10 04:11 EDT, Sona Mala
no flags Details
Actual result - Activity Instancies (43.88 KB, image/png)
2013-10-10 04:13 EDT, Sona Mala
no flags Details
Expected result - Activity Instancies (42.03 KB, image/png)
2013-10-10 04:14 EDT, Sona Mala
no flags Details
Actual result - Path 1 (57.35 KB, image/png)
2013-10-10 04:14 EDT, Sona Mala
no flags Details
Expected result - Path 1 (56.93 KB, image/png)
2013-10-10 04:15 EDT, Sona Mala
no flags Details
Server log (264.32 KB, image/png)
2013-10-10 04:20 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-10-10 04:10:14 EDT
Created attachment 810361 [details]
Video file - step to reproduce

Description of problem:
If the process contains a parallel gateway with probabilities (x,y) of outgoing flows, which are set to x:y where x + y < 200 && x <= 100 && y <= 100, then the simulation engine starts less instances (for example 60:40 - starts 2 instances instead of 10).

If probabilities of outgoing flows are set to 100:100 then the number of started instances is right.


Version-Release number of selected component (if applicable):
6.0.0 BPMS ER3


Steps to Reproduce (see attached video):
1. create a process (see attached image of BPMN2)
2. set the probability of the flow from gateway to "h2" to 60
3. set the probability of the flow from gateway to "sss" to 40
4. run simulation 10 instances, 10 minutes

Actual results:
Number of instances for each activity is 2 (see attached screenshot)
Table for path:
------------------
|Path1       | 2 |
|Other Paths | 8 |
------------------

Expected results:
Number of instances for each activity is 10 (see attached screenshot)
Table for path:
-------------------
|Path1       | 10 |
|Other Paths |  0 |
-------------------

I believe that a probability parameter is useless for parallel gateway. I think that engine should ignore such parameters.


Additional info:
Comment 1 Sona Mala 2013-10-10 04:11:59 EDT
Created attachment 810362 [details]
Process image
Comment 2 Sona Mala 2013-10-10 04:13:37 EDT
Created attachment 810363 [details]
Actual result - Activity Instancies
Comment 3 Sona Mala 2013-10-10 04:14:07 EDT
Created attachment 810364 [details]
Expected result - Activity Instancies
Comment 4 Sona Mala 2013-10-10 04:14:42 EDT
Created attachment 810365 [details]
Actual result - Path 1
Comment 5 Sona Mala 2013-10-10 04:15:19 EDT
Created attachment 810366 [details]
Expected result - Path 1
Comment 6 Sona Mala 2013-10-10 04:20:35 EDT
Created attachment 810368 [details]
Server log
Comment 7 Maciej Swiderski 2013-10-14 13:48:13 EDT
roblem was caused by invalid handling of probability parameters for parallel gateway - they should be ignored as all outgoing sequence flows shall always be taken

droolsjbpm-integration
master
https://github.com/droolsjbpm/droolsjbpm-integration/commit/34c4feae7acd71c27ce67630fa7b091e7df977ff

6.0.x
https://github.com/droolsjbpm/droolsjbpm-integration/commit/5c20c8827e7b252034e499fb4e92803c978a74bb
Comment 8 Sona Mala 2013-12-12 08:24:05 EST
Verified for ER5.
Comment 9 Sona Mala 2014-03-24 12:30:24 EDT
A test for this issue should be a part of certification matrix for Simulation features. Now, it does not exist.

Note You need to log in before you can comment on or make changes to this bug.