Bug 1017583 - Can't set data size to -1 manually during TUI installation
Can't set data size to -1 manually during TUI installation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 04:20 EDT by wanghui
Modified: 2014-07-18 11:49 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-4.el6
Doc Type: Bug Fix
Doc Text:
The hypervisor installer uses a size of -1 to fill all remaining free space for the data partition. This value is automatically set, but if a user changed it, they were unable to change it back to -1 and proceed with the installation. This is now possible.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:53:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
set data size to -1 manually (6.29 KB, image/png)
2013-10-10 04:20 EDT, wanghui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20122 None None None Never
oVirt gerrit 30425 master ABANDONED Let data-size be specified as -1 Never

  None (edit)
Description wanghui 2013-10-10 04:20:46 EDT
Created attachment 810369 [details]
set data size to -1 manually

Description of problem:
It can not set data size to -1 manually during TUI installation. But the default data size is -1. So should accept the format of data size is -1.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
ovirt-node-3.0.1-3.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso using TUI mode.
2. Change the data size to -1 in storage volumes page.

Actual results:
1. After step2, it will prompt that the file must contain a number in the bounds [0,None]. And it will not accept the setting of data size as -1. 

Expected results:
1. It should allow the data size as -1.

Additional info:
Comment 4 wanghui 2013-10-21 07:37:41 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Install rhev-hypervisor6-6.5-20131017.0.iso using TUI mode.
2. Change the data size to -1 in storage volumes page. 

Test results:
1. After step2, it can set -1 manually.

The bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.
Comment 6 Cheryn Tan 2013-11-07 19:28:03 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 errata-xmlrpc 2014-01-21 14:53:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.