Bug 1017587 - field value enumerations missing in call report API description
field value enumerations missing in call report API description
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: documentation (Show other bugs)
2.2
Unspecified Unspecified
medium Severity unspecified
: ---
: 2.3.0
Assigned To: Randy Barlow
pulp-qe-list
https://pulp-dev-guide.readthedocs.or...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 04:27 EDT by mkovacik
Modified: 2013-12-09 09:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:30:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mkovacik 2013-10-10 04:27:26 EDT
Description of problem:
Following fields miss enumeration of possible values in the docs:
  - state
  - response

Version-Release number of selected component (if applicable):
Pulp 2.2

Expected results:
Valid states and responses are enumerated in the docs for both the fields
Comment 1 Randy Barlow 2013-10-24 16:55:53 EDT
Hi Milan!

It looks like response is actually properly documented there:

    response (string) - a response from Pulp’s tasking system: accepted, postponed, or rejected

Was there something more that you needed to know about response?

I'll find out what state can be and put it there.
Comment 2 mkovacik 2013-10-25 04:55:43 EDT
Randy, thanks, I must have missed that; looking at the page, the response field is described indeed. However, the state field isn't (the second item in the Description list).
What are the possible states a Task might be in?

Thanks!
Comment 3 Randy Barlow 2013-10-25 09:48:11 EDT
https://github.com/pulp/pulp/pull/678
Comment 4 Jeff Ortel 2013-11-01 18:29:06 EDT
build: 2.3.0-0.27.beta
Comment 5 mkovacik 2013-11-04 05:25:38 EST
Checked in latest docs[1]

[1] https://pulp-dev-guide.readthedocs.org/en/latest/conventions/sync-v-async.html
Comment 6 Preethi Thomas 2013-12-09 09:30:47 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.