Bug 1017629 - Creating org with default env named or labeled 'Library' throws an error
Creating org with default env named or labeled 'Library' throws an error
Status: CLOSED DUPLICATE of bug 983994
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 05:04 EDT by Kedar Bidarkar
Modified: 2013-10-10 12:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 12:18:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
erroe upon adding Library as default env (74.27 KB, image/png)
2013-10-10 05:04 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Kedar Bidarkar 2013-10-10 05:04:59 EDT
Created attachment 810404 [details]
erroe upon adding Library as default env

Description of problem:

Creating an organization with default env named or labeled 'Library' throws an error.

Version-Release number of selected component (if applicable):
Satellite-6.0.2-RHEL-6-20131007.0/	

How reproducible:

While creating an env with Library as name and label for a new org


Steps to Reproduce:
1.
2.
3.

Actual results:
throws the below error

ERROR: update or delete on table "organizations" violates foreign key constraint "environments_organization_id_fk" on table "environments" DETAIL: Key (id)=(15) is still referenced from table "environments". (PGError)

Expected results:
Should disallow creation of an env with library as name and label and raise a proper notification.

Additional info:
Comment 2 Mike McCune 2013-10-10 12:18:20 EDT

*** This bug has been marked as a duplicate of bug 983994 ***

Note You need to log in before you can comment on or make changes to this bug.