This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1017644 - PATCH: fix qemu using 50% host cpu when audio is playing
PATCH: fix qemu using 50% host cpu when audio is playing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-10 05:36 EDT by Hans de Goede
Modified: 2013-11-16 01:54 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-1.6.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-16 01:54:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-10-10 05:36:10 EDT
qemu-1.2 and later (so F-18+) have a regression where the audio_timer tries to expires every nano second, which gets rate limited to every 250 us by the timer subsys, resulting in 4000 wakeups per seconds for vms with audio active.

Here is an upstream patch fixing this:
http://lists.nongnu.org/archive/html/qemu-devel/2013-10/msg01204.html

Dropping host cpu load to a much better 13%. And here is a follow up patch further limiting the wakeup rate from 250 / second (which is a bit much) to 100 / second:
http://lists.nongnu.org/archive/html/qemu-devel/2013-10/msg01205.html

Further reducing the host cpu load for playing audio to 9%.

Note master had some timer functions renamed, so the 1st patch won't apply as is, backporting it is trivial though.
Comment 1 Cole Robinson 2013-11-05 19:11:46 EST
Since only the first patch is upstream right now and seems the most important one, I'll just pull that.
Comment 2 Fedora Update System 2013-11-06 08:09:31 EST
qemu-1.6.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qemu-1.6.1-1.fc20
Comment 3 Hans de Goede 2013-11-06 08:12:17 EST
(In reply to Cole Robinson from comment #1)
> Since only the first patch is upstream right now and seems the most
> important one, I'll just pull that.

ACK.
Comment 4 Fedora Update System 2013-11-06 13:23:57 EST
Package qemu-1.6.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.6.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20776/qemu-1.6.1-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-16 01:54:24 EST
qemu-1.6.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.